Framework 13 DIY cant install win 11

I have just put my Framework 13 DIY together and i had a USB with Win 11 ISO installed and when i turn on the the new laptop i get a message that says
" Default Boot Device Missing or boot failed.
Insert Recovery Media and hit any Key.
Then select “Boot Manager” to choose a new new Boot Device or to Boot Boot Recovery Media. and click OK"
I am lost and just do not know what to do.
Bruce. Western Australia

Reboot and tap the F12 key. This will display a boot menu. Select to boot from the USB drive.

1 Like

I did that but there is nothing there to see

I am at a complete loss as to what to do to install Win 11 on my Framework 13. it appears as though the USB is not recognized.
I am way out of my depth, the makers made it sound so easy. Am i suppose to take it to a computer shop, please help someone!!!

Did you shut down the computer already, unplug the “usb expansion card” and reseat it again, plug in the usb stick and then turn on your computer again and try to select the USB drive then via the boot menu?

Try reflashing your USB, then plug it in and switch your framework on. Immediately start pressing F12 and keep tapping it until you get to the boot selector.

This is the important bit, when you get to the boot selector press F3. It should say on the right side something about your WiFi driver being set to ‘Fallback’. Otherwise your Windows install will bluescreen. Press enter and you should be booting into the installer

I have done all these things so many times. It appears to me that the USB with Win 11 on is not being recognised.
When i go into BOOT i can see the SSD 250GB and the HDMI expansion card but it does not show the USB expansion card nor the C Expansion card that the powe source is plugged into.

The USB expansion cards are little more than pass-throughs, so it’s not surprising that they don’t show up. However, the USB drive you have plugged in should show up as a boot option.

Have you tried re-creating the install USB? I’ve had them become corrupted when they were created and they didn’t work. It sounds like whatever is on the USB drive is not being detected as a valid boot option.

How did you create (copy) the installation devices?

I did download from Microsoft into my downloads, then copied it to the Usb. I’ll try to download it again directly to the usb this time if i can.

Have you tried using the Media Creation Tool from Microsoft? For most users this is the best and easiest method to create a bootable USB drive. Use link below and click the second option to Create Installation media.

1 Like

I’m pretty sure you can’t download the ISO directly to the usb.
You need to overwrite the whole usb stick with the installation ISO. On linux or mac you can use dd in the terminal.

You are correct that you can’t simply copy an ISO file to a USB thumb drive. The contents need to be unpacked and the USB drive made bootable. A tool like Rufus works well to handle the task.

1 Like

Many thanks
I’ll give it a go tomorrow

Hi Guys
All went well and up and running.
I used the Windows media creator on ta new flash drive i had, put in the framework and still no joy.
I repeated the same on an older flash drive, (don’t ask me why) and low and behold the framework found it and it was all plain sailing from there on.
Thanks again for your help’


@Bruce_Small enjoy your new laptop.