External GPU 4060 not working, NVIDIA installes mobile driver

Hi,

I have the Framework 13 AMD Laptop and am very happy with it. (dual boot W11 a. Mint)

Short Version:

Hooked my Desktop RTX 4060 into eGPU Adapter. NVIDIA installer installs Mobile GPU driver. How do I force install the Desktop driver?

I have the ADT-UT3G_v1.2 UT3G
eGPU USB4 to Pcie x16 eGPU Adapter

  • Seasonic 500W PSU

I tried it with a GTX 970 with an external monitor and it was basically plug and play. (W11 and Linux Mint)

It shows pcie 4 with 4 lanes on gpu-z with is what it is supposed to be showing. The speed is 80% of a standard GTX 970 witch is the speed an external gpu is supposed to have.

My problem is now with my new RTX 4060 it doesn’t show up in Task Manager after driver install. (W11 and Linux Mint)
It will be displayed correctly in device manager.
I Installed countless different driver versions. (tried a 4070 Ti as well)
I am heavily suspecting that the mobile GPU driver is installed time and time again.
How do I force install the Desktop driver?

I will try a windows reinstall on my desctop PC with the RTX 4060 pluged so correc GPU driver is installed and transfere the ssd to the laptop.
But is there a better way?

EDIT:

I have now reinstalled windows on my desktop PC with the rtx 4060 plugged in.
external monitor working and Task manager shows the 4060.
I checked the driver with NVCleanstall and it said Mobile: NO
.

Now I plugged the ssd back into my Framework laptop. And surprise the external monitor plugged into the 4060 doesn’t work. The Task manager doesn’t show the card. AND NVCleanstall shows the driver version as Mobile: YES again…

So Windows/NVIDIA switched to the mobile version again witch why it doesn’t work…

Why does windows think I have a mobile RTX 4060 when in reality its a desktop version. Is this a BIOS issue?

So how do I force Windows to use the desktop driver and not the mobile one?

I got the eGPU ADT-UT3G adapter to work with my RTX 4060

the solution was installing the nvidia-error43-fixer script by nando4

I did not receive an error43 and installed the script on a whim. It seems that Windows is hiding this error.

I hooked the 4060 to an external 4k Monitor and bench marked it and got 80% of the standard GPU mark.
So now I can game on my Framework AMD laptop witch was the point of buying it in the first place.