Framework 16 Keyboard Not Working

OS: Windows 11
Laptop: Framework 16

Hi, posting here while I wait for support to respond to my ticket. So far the symptoms seem to be similar to this post, except for me the keyboard has never worked.

Things I’ve tried:

  • Rearranging and reinserting the expansion cards (1 TB, 1 Audio Jack, 1 USB-A, 3 USB-C)
  • Using an external keyboard (this works without any problems)
  • Reseating the keyboard on the mid-plate
  • Disconnecting and reconnecting the mid-plate cable (I also do this when opening up the mid plate as instructed)
  • Verifying that my laptop is not near other laptops (I saw a thread where sensors would go a bit mucky with multiple laptops near each other)

Other Notes:

  • This morning for a little while the keyboard was lighting up with an RGB pattern, but still was not grabbing any input. As soon as I restarted the computer, the RGB went away.
  • Other than that, there has been no lighting or input whatsoever, from Caps Lock, RGB, etc. even when I use my external keyboard to enable Caps Lock
  • I was initially getting a missing input module error on boot, that eventually went away and let me install Windows; this message and the comment on the other thread suggests that it might be a mid plate/mid plate cable problem

Does anyone else have any ideas on what else to try? I tried booting in to bios but couldn’t interact with anything even with my external keyboard.

EDIT1: I just took everything off, reconnected the mid cable, and restarted my machine. I am once again getting the lights with no keyboard input :cry:

1 Like

I suspect you’ve already done this, and just didn’t mention it, but have you tried putting the keyboard on in one of the other two possible positions?

The RGB coming on, on occasion, does suggest that it’s a connection problem of some kind. The question is whether it’s a problem on the keyboard, or on the main system. That’s what trying the other positions might answer.

1 Like

Chad, you are a genius. Somehow that had slipped my mind earlier. I just tried with a spacer / spacer / keyboard configuration and now the keyboard is working.

I’d still prefer a space / keyboard / spacer configuration so I’m going to see what support has to say but I’m at least able to use the keyboard now.

Seems like since the keyboard is now working, something might be wrong with the main board? Or perhaps a connection cable there?

I did notice that the light near the mid cable (labeled 1) flashes red → blue → off → red on a cycle; perhaps that might be related.

In any case thanks a lot for the intermediate fix. :+1:


Alright, new update here, that is somewhat driving me a bit nuts now.

It seems like maybe the keyboard itself is fine, but something about the physical pieces slotting together that might cause issues?

I fiddled around with it a bit more and noticed that sometimes I can seem to cause some combination of the keyboard / touchpad / LED spacer to not work.

In particular, the touchpad piece seems to not fit very nicely, sticking up a little bit as shown in these photos. HOWEVER, in these photos everything is working. If I try to do some positional adjustments some combination of the following occurs:

  • Keyboard stops taking input
  • Keyboard light turns off
  • Touchpad stops working
  • LED spacer turns off

But seems like different minor adjustments are causing different bits to be disabled. :cry:

I’ve kept it as is in the photo for now as it at least works but I am still pretty worried…

1 Like

Could you take additional pictures?
The touchpad looks like its side edge is sticking up a lot. Is it’s the front edge hooked under correctly?

This is my current setup that has all pieces working. Can provide more photos as needed. I am sadly a new user so i can only embed two images at a time.

Im a bit hesitant to make adjustments right now since it is all working, but my own observation is that the spacers and keyboard are flush. The right and bottom of the touch pad seem flush as well. Im beginning to wonder if perhaps the shape of the touch pad is the problem and perhaps the earlier keyboard problems were a symptom of mispositioning.

Two more.

Last ones

Notably the corner seems to…bend upward?

Oh yeah, that’s certainly not right.
Not sure if it’s related to your connection problems.


Appreciate the input, it’s always good to get a second opinion even when reality is staring you in the face haha. I’m suspecting that it might be related; it could be that earlier when I hadn’t noticed the touch pad deformity I was positioning my pieces incorrectly or something. :sweat_smile:

Alrighty, I reset the midplate and things fit much more nicely together.
However, the original problem still persists.
I’ve attempted the following configurations:

LED / Keyboard / Spacer
Spacer / Touchpad / Spacer

Keyboard shows no activity, and mostly does not light up. Very rarely it will light up with RGB colors but remain unresponsive. Touchpad, fingerprint scanner, LED all appear to work just fine.

LED / Keyboard / Spacer
Spacer / Spacer / Touchpad
No keyboard activity

LED / Spacer / Keyboard
Spacer / Spacer / Touchpad

This is the only configuration that all components appear to be functional on. The visual issue with the fitting piece is now gone, perhaps a red herring I introduced while trying things out.

Keyboard / Spacer / LED
Spacer / Touchpad / Spacer

No keyboard activity

Keyboard / Spacer / LED
Touchpad / Spacer / Touchpad
No keyboard activity

1 Like

It looks to me like a hardware problem.

You’ve got enough evidence that it’s not user error now. I’d say it’s time to open a support ticket.

1 Like

Yep, thanks for the advice. I’ve opened a support ticket and will update here with what ends up happening.

So far they’ve just asked me for a bunch of photos of the packaging, the laptop itself, and to reseat the midplate (which did help with the touchpad fitting).

Since it seems to be configuration specific my semi-educated guess would be something with the midplate or the midplate cable.

1 Like

Sent a ton more photos for documentation purposes (top and underside of spacers, keyboard, touchpad, midplate, etc.)

Was also directed to reinstall drivers and retighten the midplate.

They have concluded that I need a new midplate and touch pad and asked for my shipping information; I’m unsure if something is actually wrong with both of them but it could be that they are covering their bases either way.

Very solid turnaround time overall, I am pleased with the speed of the customer service and was happy to provide more information to hopefully help them out as well.

:+1: The midplate is what I suspected. The new touchpad shouldn’t hurt anything either.

Glad it’s all working out for you. :smile:

Happy to hear that you are pleased with your experience with the support team so far. Our part replacement team is is a bit backlogged and it might take some time before they can ship the replacement parts to you, but it should be on their way soon. please let us (and the support team) know if the mid plate and touchpad replacement does not solve your issue.

1 Like

Sounds good, will do!

The turnaround time is a bit long but fortunately in my case since I have a working configuration I am able to use the laptop just fine until then. :slight_smile:

1 Like