Framework 16 not recognizing 180W AC adapter

I’ve had my Framework laptop for one day now, and for the day that I was able to use it, it was great.

Today, however, I noticed that the AC adapter (the 180W one I got from Framework) wasn’t charging the laptop. It seemed to function fine otherwise (and rebooting and BIOS entry
all worked), but I got down to about 14% battery without being able to make it charge.

I have a 65W adapter that I use for my phone, and when I plugged that in, it recognized the charge for about 5 seconds, then disconnected again.

Based on other threads about this topic, it looks like it might be some sort of mainboard problem, but I can’t figure out how to reset it.

I created a support request for this issue as well. If anyone has any more information about what I could do to try testing my laptop and fixing this problem, I’d appreciate it. I’ll also update this thread with more information from the support thread or the solution to my case, if I find out what to do.

Have you tried a different cable?
There was a recent very similar Reddit post

That appears to have done the trick, at least as far as getting a solid red light on the charging port goes. I’ll see how it works with charging speed before resolving it as a full solution. (The cable I was using for my 65W adapter suffered from the same problem of being unreliable. I got unlucky with both cables being defective, making me think the computer was the problem when it wasn’t.)

Kind of weird that the factory-shipped charging cable would just stop working like that after a day, though. Maybe it was a manufacturing defect in the cables? Would that kind of thing be covered under warranty?


Update: The charge rate appears to be about 30 watts (estimated 2 hours and 15 minutes to charge from 15% to 100%), which makes sense considering the cable I found is pretty flimsy and was probably meant for a phone charger. I’m going to buy a 180W cable off of Amazon and see if that brings the charging speed up again.

2 Likes

Can confirm that the 240W cable I bought on Amazon allows the laptop to charge at the full 85 watts now. If your laptop was from Batch 14 and it’s running into this problem, you may need to simply buy a new cable from a third-party vendor to get the power brick working again.

For some reason I can’t edit the original post to mark it as solved, or add the solution to the original post so people don’t have to scroll down?

1 Like