High Battery Drain During Suspend (Windows edition)

I’m seeing higher-than-expected power draw during sleep in Windows. I put it to sleep (fading power button LED) for 6 hours and the battery level dropped about 33%, which seems very high at 5.5%/h. Comparing this to my X1 Carbon which drops by ~0.6%/h (57Wh capacity). Both are using modern standby I presume, and I’ve configurd both to not hibernate.

Folks on Linux seem to be seeing similar drain rates. Is this something that can be improved in firmware?

How should I troubleshoot this? I disabled wake on lid open so I’m fairly confident it’s not waking itself.


If you run powercfg /a from a command prompt, what sleep states are available?

1 Like
The following sleep states are available on this system:
    Standby (S0 Low Power Idle) Network Connected
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.
        This standby state is disabled when S0 low power idle is supported.

    Standby (S2)
        The system firmware does not support this standby state.
        This standby state is disabled when S0 low power idle is supported.

    Standby (S3)
        This standby state is disabled when S0 low power idle is supported.

    Hybrid Sleep
        Standby (S3) is not available.
        The hypervisor does not support this standby state.

Only having S0 available explains the high drain.

Did you install the Framework Windows 10 driver bundle from here? Windows 10 Installation on the Framework Laptop DIY Edition - Framework Guides

I did. I was under the impression that Modern Standby was efficient. On the X1 Carbon, which has identical powercfg /a output, power draw is an order of magnitude smaller. Is the X1 cheating somehow?

You are correct, I was thinking S1 instead of S0 low-power idle.

What SSD is it?

I’m using a 500GB WD Blue SN550.

A quick search turned up this:

Not sure if this is relevant, but apparently there are NVMe drives that don’t work with Modern Standby? Event Viewer doesn’t show any unexpected wakes though.

Side note: I have it plugged in and sleeping, and can feel heat on the underside. So it’s definitely doing something

Hi, thanks for reporting this! Could you try running “powercfg.exe /SleepStudy” as administrator and checking what the report that it outputs says?


Wow, didn’t know about this capability! Here’s the report.

The offending sleep session is entry 169:

And the top offender looks like the audio controller:


@feesh the audio controller should shutdown in modern standby unless you put the system in modern standby with an application that is playing/recording music. One of the “features” of modern standby is your system can continue to play music while in standby, however it will keep the CPU from going into deep sleep states to service the HDA codec audio buffers.
I suspect you put your system to sleep with an application that was doing some playback/recording and noticed this.

We have tested modern standby support extensively and if your system is not being kept awake by an app/service, it will go into MS and then hibernate if the 5% battery drops by more than about 5%.


Thanks @Kieran_Levin. I wasn’t explicitly running any audio applications but I’ll double-check for anything running in the background.

1 Like

An update. I closed all my background apps (HWiNFO, MSI Afterburner, Discord) and the Audio Controller is still preventing the CPU from going to sleep:

Is there a way I can find out which process or service is keeping it active? Could this be an issue with the Realtek audio software?

Do you have a browser tab with media in it maybe?

If you really want to dive into it, looks like Windows Performance Analyzer is the tool for diagnosing modern standby: Using Windows Performance Analyzer to analyze Modern Standby issues | Microsoft Docs

No browser running.

Thanks for the WPA suggestion, running a trace now.

I ran the trace but I’m not sure what to look for. This is a ~2.5h sleep session after a fresh boot with all my startup programs exited, so I’m sure that I’m not playing or recording any audio. SleepStudy still shows 100% active audio controller.

Here’s one of the graphs. Anywhere else I should look?

I’m out of ideas. But the WPA looks neat so I’ll try it on mine tomorrow if you haven’t figured it out by then.

This isn’t the right solution for this, but I am curious what happens with that if you uninstall the Realtek audio driver and use the Windows default HDA driver.

Thanks, I’ll give that a shot!

1 Like

Yes, that seems to have worked!

It is still red, but 1%/h is much more in line with expectations! This is the cause of the red for those curious:

EDIT: Another, longer session (2.6%/h):


Thanks for helping debug this! We’ll dig in on the Realtek audio driver to see if we can replicate this and understand what is happening.