[IN-TICKET] Windows 11 2H22 fails to install with 0x8007001f error

I had been trying to update my Gen12 DIY Framework laptop to Windows 11 build 2H22 for quite some time and had been getting a 0x8007001f error. Near as I can figure out, that means that some device is not ready. I’ve turned off BitLocker to decrypt the drive and I’ve used msconfig to disable all the non-Microsoft services and disabled all startup items in the task manager, but it always gets to 77% (nice), restarts, and then tells me the update has failed. I can’t seem to find any more specific error codes for the error. I’ve tried running the Windows Update Troubleshooter and it tells me that it has adjusted some settings, but I still get the error. Where can I look for logs that will help narrow down what device may be causing the issue? Or what other things can I try to install the update?


@Kenn_Murphy Hi and welcome. Which expansion cards do you have? Wondering if one of them might be the problematic device; have you tried running the update without expansion cards?

I also found this on MS for a similar error, not sure if it applies but might be worth a look.

Thanks for the help! I am trying your suggestion now. I have also suspended BitLocker. If that doesn’t work, I’ll check out the suggested link as well.

No luck. I was able to get more info about the error using the SetupDiag tool. The sub-error (not sure what the correct term is) is 0x000000b7 which looks to be an INACCESSIBLE_BOOT_DEVICE error. The drive works fine otherwise. Not sure, but I’m going to check some bios settings and I’ve applied the latest firmware that I could find on the Framework site.

Edit: Correction. Looks like the additional error info was 0x60016, which I’m still not able to find anything about.

Hi @Kenn_Murphy,

The best approach is to open a support ticket so we can help get this resolved for you. Since our support staff focus on resolving issues of this nature in a ticket form, this is going to be the recommended course of action.


Oh, thanks! I didn’t think this would be a support ticket issue. I will do that now.