Issues with new laptop

Hello, got my new DIY laptop up and running, kinda of… Here are my current issues

  1. randomly powers off/reboots seemingly tied to when I pick it up, slightly move it on my lap, etc.

  2. USB-A mouse won’t install so cannot use it. I don’t see any lights on any of my 4 expansion cards

  3. HDMI port won’t push to the monitor I want to use and I tried all settings, (duplicate, extend, 2nd screen only, etc).

1 Like

Have you made sure your battery connection is solid to the mainboard? I would disconnect and reconnect just to make sure it is seated properly.

If the mouse does not start working automatically this usually means that drivers for it are not available. You will need to go to the manufacturer’s website and get the driver to install.

Are you sure the hdmi cable you are using is up to the task? Have you been able to use the cable with anything else and it works?

Of course your mainboard could have some problems as well. I just think the things I’ve said above make more sense, and in the world of electronics working from the most likely issue to the most obscure is general the preferred plan of diagnosing things.

Of course, this is the community forum of Framework. if you’d like official support please write Framework support directly via email.


Hello and thank you for responding. After my PC auto rebooted several times it seems Microsoft finally loaded my background screen saver from my other PC and then auto installed the mouse. Seems to be windows profile related.

I have not messed with the power supply as seems to be something else. I disabled the windows lock screen in the registry as I confirmed the display connection was sound but screen kept going to lock screen, like constantly sometimes a dozen times in a minute back and forth. Disabling the lock screen helped that part but still randomly crashes and reboots. I don’t think it is losing power as after I fixed lock screen seems to go for a while then will randomly without movement now just reboot. I think the constant locking and unlocking while I’m working was causing more consistent crashes and reboots. I was using the same HDMI cable for the same monitor for my desktop PC. It is not a new HDMI cable so are you saying my new framework PC requires a new or certain kind of HDMI cable?

I should have asked this first, but I digress:

Did you install the Framework provided Windows Driver package?

If not, you can get them from here:

and should install them right away. You might also want to update the BIOS of your machine with the link provided there as well. Simply open the files provided there, one at a time, and see if those help you with your issues.

I also have one issue I have come across. My OS is W10 although that may not be relevant.

I use Macrium Reflect and on the rare occasions I boot direct into it from USB, I have noticed that the trackpad mouse does not work.

Similarly, because of a different issue I was having, I ran Memtest86 last night from a boot USB. I could see a mouse cursor but it did not recognise my trackpad mouse.

Have I missed a setting in the BIOS? Anyone else notice this?

@njf, that isn’t really what this thread is about, but you might need to mess with the mouse emulation setting in the bios. Just search here on the forum for mouse bios setting or something like that. You should find some information on it.

Not having the trackpad work when booting off of the Macrium recovery media is more an issue of the Macrium. They control what drives get bundled with the kernel they are booting from. So changing the mouse emulation in the bios might let the trackpad work with whatever generic driver they are loading.

Thanks, @2disbetter. I didn’t mean to hijack the thread. I will try what you suggest and will start a new thread if I still can’t solve the issue.

1 Like

Do you have magnets on the desk or surface where you’re putting the laptop?

Naw, I don’t have any magnets. Just my laptop on a wood desk

Hmmm, then I don’t know. I’ve seen reports of this sort of behavior because the lid sensor gets triggered (it’s on the left side of the laptop about half-way).

Where is the lid sensor? I don’t see anything on the keyboard, side, display etc

I downloaded the windows driver bundle from the DIY get started blog. Is that not the current BIOS and drivers, etc? Sounds like the link you provided is for tempo motherboards or something that I’m not sure that I have?

It’s in the chassis, you won’t be able to see it (unless you open it up, I guess…?).

The files there are the stock versions. There has been 2 updates since then, but both are still in beta I believe. 3.06 is the current beta BIOS version, which I linked above. It is appealing because it improves a number of things, but none of those things are relevant to the issues you’ve highlighted here.