Just arrived and display won't power on

My Framework 16 DIY Edition just arrived! I excitedly opened it up and installed a 2TB Samsung 990 Pro SSD and 64GB of 5600 DDR5 RAM from Crucial, replaced the metal plate, tightened all the screws, pressed down the [1] connector, attached the keyboard, touchpad and spacers, plugged it in, inserted the USB stick with Windows 11, pressed the power button and… nothing.

Well, the power LED lights up, and I can hear the fans if I listen closely, but the display shows no signs of life.

The little LEDs on the side are flashing: red, blue, off, red, blue, off

Obviously suffering enormous disappointment here, any help or suggestions will be gratefully received.

Are you leaving it on? There’s varied reports of how long “memory training” with new memory takes, maybe 20 minutes or so on the high end.

2 Likes

Similar situation - nothing on screen at first boot.
I don’t have any special lights, just white around the power button and solid red on the side (which I guess is just charging?)

You’d think someone (AMD? Bios provider? FW?) would have implemented a visual feedback for the ram training process :confused:
Or maybe a bit more detail in the build guide.

I am using 32GB sk hynix ddr5 5600.

3 Likes

If it’s not just that you need to wait for memory training, other things to check is if your ram is fully seated. It should click to lock in. It can also be worth it to try with only one memory stick.

If you have let it train for a while and are still having a problem then I would try booting it with just 1 memory module installed. It is entirely possible that it is a bad memory module.

1 Like

You could try reconnecting the display cable as well. Might’ve been loosened in shipping or after qc quick at the factory.

Few Pictures might help.

Also this page show how to read the LED Blink:

1 Like

Sorry, forgot to post the photos.

Everything:

SSD and battery connector:

Memory (2x Crucial 16GB DDR5-5600 1.1V CL46)

WiFi module:

Expansion port (no GPU):

Right side:

Left side:

Leaving it on for a while. If there are really people waiting over 20 minutes for “memory training” with no visible user feedback or mention in the instructions that that’s what’s going on then Framework need to fix this, if only with a piece of paper in the box that says “initial startup takes ages, maybe go have a nap.”

3 Likes

I’ve looked at the page that shows how to read the LED blinks and it says there should be white, then 12 that are red or green, but mine just goes straight to “red, blue, off, red, blue, off”

can you provide a picture of the blink codes?

What’s the charger that you’re using? Few week back I was setting up the Naked FW 13 11th gen and I couldn’t get any display while using 30W charger. Changed to a 100W and it booted up.

I’ve resolved my issue - reseating the ram modules seems to have fixed it.

Tip for anyone else - turn on the machine after you install the ram, but before you put the midplate back.

That way you can troubleshoot without having to disassemble it again.

(Then turn it off again before continuing)

7 Likes

Reseated the RAM, tried leaving each of the modules out, no difference. Also removed and reseated the SSD just to be sure.

Checked the display cable, seems fine as far as I can tell.

I’m using a 200W UGreen USB-C charging hub that outputs 100W; I didn’t order the official charger (for some reason that eludes me now).

Similar issue here. Using the official charger, but getting the same issue.

1 Like

I’ve opened a support ticket, will update here when I get a response.

1 Like

My issue was resolved by removing the wifi card. I had installed an intel be200 I had, but it looks like the laptop didn’t like that. Hope this helps others.

1 Like

That card has been well established through the FL13 AMD as not allowing the BIOS to run.

1 Like

It’s even worse than that, somehow the card and the cpu really don’t like each other, even if you plug it in after boot via thunderbolt it hard crashes the system as soon as it connects XD.

Hope that gets fixed in a future agesa update or something.

I have the Mediatek RZ616 that came pre-installed.