Keyboard not working on new 12th gen batch 3

I’ve just set up my new 12th gen batch 3 laptop and the built-in keyboard doesn’t seem to work. I’ve followed the recommended steps to resolve this without success. (My keyboard isn't working).

Using an external keyboard I booted into an Ubuntu live os. And the touchpad works, but not the built-in keyboard.

1 Like

Can you send an image of the back of the keyboard? It is most probably a cable not plugged in correctly.

Hopefully you can see what you need in these pictures.

Looks like this latch is flapped up?

Could cause a bad connection.
Check that the cable is seated properly too

I tried reseating the connector yesterday, and I’ve just double checked, the connector is inserted correctly and the latch is down. Also, the touchpad works fine, but the keyboard doesn’t work at all.

I am having a similar issue where instead of the Keyboard, the lid sensor stopped working once I upgraded to the 12th gen Mainboard. The connections are fine and everything else works flawlessly (fingerprint reader, keyboard, touchpad) but the lid sensor stopped working.

That might be solved by a bios reset. Most likely, it is not recognized by the bios, since the hardware is the same.

How do you reset the BIOS?

After a discussion with Framework support they’re sending me out a replacement input cover. Hopefully that will solve the issue.