Laptop won't detect phones

I have tried to connect my android phones, using the usb a to c cable and usb c to c ports, and they don’t get detected. I looked in device manager and do not see any devices.

I stuck a usb drive, in both ports, and see them fine. I’ve tried different phones and different cables. None of the android phones get detected.

Even tried downloading the samsun usb drivers and still no luck. Anyone else having the same issue?

Normally when you unlock the phone and connect it to a computer it will ask you to trust the computer. I would then click yes and have access to it.

In some cases the phone automatically puts itself in a charge-only mode and you would want to modify that one to switch to mtp.

This of course depends on which OS you run on your phone and it’s version, so I can’t generally give you advice on how to do this.

1 Like

You don’t have to connect your Android smartphones to the laptop via a wired cable. There are third-party apps on the Google Play Store that, as long as both the laptop and phone are on the same network, enable wireless file transfers via web access: you point the browser on your laptop to an IP address provided by the app, use the password also provided/generated by the app, then download/upload files to/from your phone.

Failing that, use the sneakernet approach and do your file transfers via external USB storages. It’s a few extra steps, but it gets around that “phone not detected by laptop” problem entirely.

Yeah that’s what I tried to do, change from charging to mtp transfer, but it doesn’t even detect any usb connection.

The same phone she same cable in my desktop works though.

Which configuration do you have? Which OS and version are you running?
What is listed in the system logs when you plug your phone into?

Android 13, rooted and adb enabled
Windows 10
Nothing happens in the system logs when I plug in either usb a or usb c

I was talking about the Laptop. Which configuration do you have? (11th, 12th?)
Do other devices get events in the system log when you plug them in?

Also I am confused about this:
usb a to c cable and usb c to c ports
You should connect them directly, preferably using usb c to usb c on a usb c expansion card (port) or using usb c to usb a to a usb a expansion port.

On the laptop’s USB A port, when I plug in a USB flash drive, nothing happens. This flash Drive also has a USB C port, which I connect on the laptop’s USB C port and it works.

When I use my first cable (USB A to USB C), nothing happens when it’s hooked up to the laptop. When I hook up my second cable (USB C to USB C), nothing happens.

What I deduce from that is probably that the USB A port, on my laptop is not working. The USB C port module works, but not when it comes to hooking up my phone.

Make sense?

OS Name Microsoft Windows 10 Home
Version 10.0.19045 Build 19045
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer Framework
System Model Laptop
System Type x64-based PC
Processor 11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz, 2419 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date INSYDE Corp. 03.02, 7/1/2021
SMBIOS Version 3.3
Embedded Controller Version 255.255
BaseBoard Manufacturer Framework
BaseBoard Product FRANBMCP03
BaseBoard Version A3
Platform Role Mobile

This may not be the cause, but I noticed that your BIOS is quite a few releases older than the current version 3.17. BIOS updates also bundle embedded controller and PD (power delivery) controller updates, so there might be some interplay between those and what you’re seeing.