Problems with the Power Adapter (not the cables)

I’m having difficulty charging my laptop with the adapter. I’ve already had to replace the usb-c cable but that doesn’t seem to be the issue this time. If there’s a problem with the adapter itself is the only option to replace it? Is there any way to make sure that’s the problem and there isn’t something else?

*I’ve checked to see if the usb-c to usb-c cable I’m using works - it does, it connects my phone to my laptop perfectly fine

  • no visible damage on either of the cables
  • Checked for damage on the power adapter; there’s superficial scratches but no noticable damages
  • Nothing is audibly rattling around in there (that’s happened to a power adapter for a previous laptop of mine)
  • I have a phone charger that’s a usb-d to usb-c that does sort of work (badly) at charging the laptop, which at least indicates the laptop is capable of charging
  • The adapter doesn’t appear to be able to open and I don’t think it would probably be a good idea to try?

My Framework: Windows 11 Home, 11th Gen Intel, FW batch 6

1 Like

Make sure you have a proper power delivery capable cable not not some cheap cable for charging smartphones. Look into cables “with E-Marker”. Otherwise, your phone might connect to your laptop, but you won’t be able to charge with proper current.

Does your phone charge on the Framework adapter with a known good cable? If not, the Framework charger is likely broken. No, you probably can’t repair these, due to the high voltage inside they’re probably glued or welded shut for safety, and opening these would be dangerous. Ask support to get it replaced if still in warranty.

SO I was pretty sure I’d checked charging my phone with it but I couldn’t remember if I had or not so I tried it this morning. It worked but that seemed weird so I tried charging my computer again and now that works too ???

But I SWEAR I tried everything last night and it wouldn’t work, I’d made sure it was plugged in securely, etc etc. The outlet, power bar and circumstances are the same so I don’t know what happened?


  1. False alarm, problem solved?
    or 2) something may still be wrong just because it’s working now and I should get a replacement just in case?

What I will probably do is assume 1 (sorry for wasting everyone’s time!) but keep an eye out for further problems just in case it’s 2?

I realize I wasn’t very clear! I bought the replacement cable months ago and it’s been working fine since. I made sure to get one that would work with my laptop too (actually it was my second cord since my first one I was TOLD it would work for my laptop but it was just a phone charger grade but that’s another story).

But thank you for your suggestions, checking to see if my phone would charge was a good idea and seems ?? to have shown me there wasn’t an issue. Thanks for your time!

It could have done a safety shut-off due to a short circuit (could be caused by liquid or dirt inside the connector) or overheating maybe. That probably fixed itself by resetting the fuse, cooling down or by plugging in your phone or something like that.

I’d continue to monitor it, but there’s probably no reason to buy a new adapter.


Oh, that makes sense, especially after a few hours off an unplugged.

Yeah, I think that’s a good idea: don’t get a new adapter but keep an eye out for any issues.


My current MSI laptop has an issue right now with a frayed DC cable, I am planning on getting a framework laptop shortly so was thinking I may as well just buy the adapter right away as I saw that the framework power adapter gets around this issue of fraying by just using a plug in usb c cable. I’m wondering however since some user how easy is it to replace the usb c adapter on the adapter itself?