Memtest & installed OS

Hi all,

I suspect I have bad RAM. I’m hearing some confusing things from framework support, and was hoping to ask for clarification from folks here.

TLDR: if I’m running memtest by booting from an official passmark USB stick, would it matter that I have arch installed as my base OS on the internal SSD? Framework support tells me arch is the issue, and I need to install ubuntu or windows and run memtest again but this doesn’t make much sense to me.

I’m running arch linux on the DIY edition. It came with one RAM module purchased from framework at the same time as the laptop. I purchased a second RAM module from the framework marketplace after it opened.

I’ve had intermittent kernel panics since receiving the laptop. I chalked these issues up to problems I’ve read about here with arch, but after upgrading to the 5.15.x series (Linux lake 5.15.11-arch2-1 #1 SMP PREEMPT Wed, 22 Dec 2021 09:23:54 +0000 x86_64 GNU/Linux) from what I’ve read things should be much more stable than what I’m experiencing.

I had trouble flashing my own memtest stick (I used the UEFI image but couldn’t get it to boot for whatever reason) so I just ended up ordering an official stick from passmark. (The MemTest86 Pro USB Flash Drive)

I can boot from that with no problem (and appreciated the notes I found here about adjusting the display settings to make the test results visible on the framework) and run the tests.

Memtest shows failures on the first run and won’t continue with further tests. I’ve tried multiple times with the same result.

Anyway from what I’ve read that all points to bad RAM sticks. So I finally contacted framework support to ask about sending them back for replacements. They told me since arch wasn’t supported, I would need to install a supported OS and then run memtest again.

I clarified that I’m not running memtest from the internal SSD where arch is installed, but from the passmark USB stick directly.

I was told:

Different Linux OS versions, distros & flavors may have different kernels that comes with them. And any system can get erratic if they don’t meet with the BIOS & kernels required for the hardwares/softwares.

In these instance may i suggest for you to update the BIOS to the latest 3.07 as well before trying out other steps possible in ruling out the RAM issues you are getting.
pls check this link : Framework Laptop BIOS and Driver Releases

Before I attempt to update the BIOS (which I’ve seen other folks having trouble doing from linux recently, maybe that’s changed, but I don’t want to totally brick my lovely laptop yet) I just wanted to try to clarify the results I’m seeing from memtest.

Why wouldn’t I be able to rely on the results of memtest, just because I have arch installed on the internal SSD?

I just ordered a 250GB expansion card so I can try putting ubuntu on it if I need to (and it’ll be nice to have anyway) but I still can’t wrap my head around why that would make any difference here.

Not an expert, but here’s my take:

The OS on the SSD doesn’t matter - you are booted from the USB. You could pull the SSD and re-run, but I expect that you will get the same results.

It looks like the new ram stick is bad and needs to be replaced.

Yup! You are booting memtest instead of the operating system, so there’s no way it could be related to you using Arch. This is probably an overly-broad interpretation of the new support policy @TheTwistgibber explained in OFFICIAL - Linux and Framework Support - PLEASE READ, and is incorrect on the part of the support person.


Very helpful to know, thank you! I’ll follow up with support and try to clarify. (The policy makes sense, but I’m glad it doesn’t apply here and I won’t have to install a new OS just to double-check my RAM issues.)