Monitor input timing not supported (12th gen, Windows 11)


I am receiving a “Please change your input timing to 1600x900@60Hz …” error message when connecting my external monitor via HDMI . I went into advanced display settings and I am already set up with 1600x900@60Hz and have tried multiple other resolutions which didn’t work either. This monitor was working with my other laptop but not with the framework.

This is on my DIY 12th gen with Windows 11 installed, and I have installed the latest driver bundle as well. I also double checked and the driver specific to this monitor is also installed.

Any ideas what I may be missing?

What is the monitor in question?

@Second_Coming, a Dell E2011H. It is old but has worked with both my previous PCs and Macs as well.

That monitor doesn’t seem to have HDMI natively…you’re using some adapter in-between?

That is correct (sorry for omitting originally). I’m using a DVI to HDMI converter which I think should be fine based on a quick Googling, but I’m admittedly not a master of signal types/conversions.

Maybe give Framework Support a call. That resolution should work without much issue with most things.

1 Like

That’s what I was thinking too, just wanted to put in a good faith effort of seeing if other folks had experienced this first and reading through the forums.

Thanks @Second_Coming!

Hi there, I’m experiencing a similar problem: my external monitor won’t connect via dvi to hmdi on windows 11. Running ubuntu from usb, i was able to connect my framework (12th gen) with the monitor in question. @t_huggy were you able to solve your problem?

@jay_tom, I went down a SERIOUS rabbit hole of even calling the monitor manufacturer (Dell in my case) and they assured me my setup should be functioning appropriately, and that the issue is likely on the laptop side of things. Framework was kind enough to send me a replacement HDMI expansion card which didn’t appear to fix the issue. What DID work for me was I bit the bullet and bought a VGA to HDMI converter (my monitor also had a VGA output) and used that instead of the DVI converter. Super weird and frustrating, but it works. I hope that helps!

1 Like

Thank you for answering so quickly @t_huggy , I really appreciate any kind of info I can get about this weird bug - it seems to me as if we’re really having the same issue. Glad to hear that you were able to solve yours with hardware, buying a VGA-Adapter is my last straw, too. But like you I am super frustrated right now as well - googling around I found the recent 22H2 build to seemingly cause the issue, but for some people a simple “hard reboot” worked. And I’m certainly done updating drivers… So I’m gonna do the same as you did and go for the VGA-Adapter.


Yup, I’d suggest giving that a go. I spent countless hours talking with Framework support and the community, Windows support, and Dell support and none of the suggestions worked. I tried about 15 other suggested tests/workarounds (not listed in this thread) suggested by these folks and sadly none of them worked. The VGA adapter wasn’t my favorite solution but it was worth the time savings for me to just buy something and call it done. I hope it works for you too!

1 Like