New Laptop Won't Charge/Turn On

Did that too :frowning: no dice

Yeah pretty much. I liked the idea that I’d be able to replace parts if I need to in the future but I didn’t plan on putting it together.

1 Like

This is a long shot, but have you tried removing and reinstalling the ram modules, as well as plugging the charger into each of the four ports (via the usb-c passthrough)? Best of luck, sorry that you are having problems with the machine. Hopefully the support team is able to help you out if nothing works.

Apologies for the delayed response. Batch 3 orders shipping and a Linus video going live means our support team is buried under requests from people wanting to invest (no, we are not accepting additional investment) or wanting to order additional modules (Marketplace coming soon!). I found your support request and bumped it up the queue to get resolved. If the side LEDs are not coming on in any way, and you’ve confirmed that the power adapter functions, that is highly likely to be a dead unit. One last possible item to double check would be removing the USB-C Expansion Card and trying plugging power directly into the USB-C receptacle on the laptop.


I dont know how to do that or where it is or what it looks like <3

Thats ok I know you guys are busy!! I was hoping to resolve it by asking here but apparently it was more complicated than I thought :frowning: I got the email I appreciate it <3 Take as long as you need ! Also yes I did plug it directly into the computer without the expansion cards, I tried all four slots.

1 Like

Welcome to the Framework community! Learning more is good. One thing to note is that various pieces inside the FW laptop have QR codes on them that you can scan from your phone with a bar code app (even while waiting for a replacement) to read about each part (though mainly about replacing/installing it). You could also do a web search on “parts of a laptop”, see overviews like Laptop Components Explained or PS Hope you get your FW up and running soon!

Thank you so much! I’m gonna look at this in depth when I get my new one in. Maybe I can learn to be a little more hands on with it!

Support emailed me back and they’re already sending a new one out! I’ll see if I can send mine back after work today. Thanks to everyone who gave it a shot and thanks to everyone who taught me something new! If yall wanna keep teaching me your little tech secrets I welcome them happily!!


Once you verify your replacement is working properly, don’t be afraid to take a look inside.

Framework actually encourages you to do so and their support guides will guide you every step of the way and explain what everything is, where it goes and what precautions to take.

Don’t be intimidated! Get in there and take a look, if you read those guides first you won’t break anything.

1 Like

Quite OT but speaking of cats taking over things: Chair so “bumfortable” my cat keeps trying to steal it while I’m working

The “I Tried That” site also has my latest Framework write-up, at Buy a Framework Laptop now to avoid buying your next few

Ok the status updated and I’m getting it WEDNESDAY but thats ok it’ll be my little treat for working so much. I have been SO ready for this I am excited to have my little boy


BOY ACQUIRED. LOVE BOY. PERFECT BOY. They also sent me another charger and screwdriver which? They told me to keep the last ones so should I send them back or do I just have multiples now…


I bet the energy/money needed to send the items back outweighs the benefit FW would get from the return.

Buy something else from them - that should make up for it.


Like a perfect romance, glad it ended well!

My DIY unit was shipped with the battery connecter physically disconnected. Was hard to find troubleshooting info until I was about to contact support. Only then did a link to troubleshooting information show up describing my symptom and the solution. If this is normal, the setup guide should say so. The link went to this KnowledgeBase listing that covers this issue: My Framework Laptop is not powering on

My dad learned to check the connections years ago when he spent four plus hours diagnosing why a copier wouldn’t work.
A fusible link was broken, inside.

After that, first thing was to check connections and continuity.

Regarding this… my batch 2 unit somehow slipped back into “kick start” mode, with a power supply connection being required to turn on the laptop. Eventually, it just stopped turn on at all (except for a few random occasions). I had a dialog with Support, and they agreed to replace with RMA, which I guess is part of batch 6.

Hopefully this helps someone else.

I believe RMAs are given highest priority, actually. @nrp can clarify, but I believe this was mentioned earlier.

1 Like

Hello, I’ve just encountered this issue on mine after having the machine for a few months. The laptop sat for about 3 days plugged into hdmi on a TV while shut down. When I went to power it on to patch linux, there was no indication of any activity from the computer. I tried it with two different supplies capable of powering the machine. After this I figured it would be something with the battery passively discharging below the threshold of operation. It seems that the Framework laptop has pretty poor battery management. I shut down the machine and disconnected the battery and was able to successfully start the computer on external power only. I think I need to put in a support request for a replacement battery. I’m wondering if there is a possible firmware/bios update to increase the shutdown threshold to preserve the battery voltage, as it stands currently the Framework machine will self-discharge below the safe discharge voltage with normal operation.

UPDATE: In my research I found that version 3.06 of the BIOS has a known issue that will cause this problem. See the following My Framework Laptop is not powering on
It seems that 3.07 was released with the fix: Framework Laptop BIOS and Driver Releases

First you should remove the RTC battery, be careful:

Then should upgrade to the 3.07 BIOS that addresses this issue:

There should be nothing wrong with your battery. What happened is that the rechargeable RTC battery ran down and was unable to negotiate charging for the main battery. This has been addressed in 3.07.

1 Like

@Legend_Lore_Cox I’m sorry to hear that you were having issues with the battery life on your laptop. I am glad the BIOS update was able to fix it for you, however! :orange_heart:

1 Like