No boot option

Hi, i receive my Framework DYI device today and unfortunatele i am not able to boot into a windows install device.
tested with usb win11 stick and with win11 boot CD via usb cd-rom
wb black sn850 has the latest firmware. the disc hgas been test on antoher device and works fine.
can somebody please help me?
would it be dead on arrival?
Thx + regards

1 Like

What do you actually see then? the framework logo and then an error saying no boot device? Are you able to get into the Bios and see what devices are detected?

1 Like

Yes i see all exterenal device in the bios (tested 2 usb sticks + one cd drive) test win10 and win11.

everytime when i leave the system booting it does not recognize any boot device… but in bios they are shown…

have tested the sticks on another computer. both are working well.


pic4 shows the usb stick connected to the usb-a expansion card.
pic3 shows the usb stick directly connected to the internal usb-c port. have used a anker usb extension… (usb+hdmi+NIC)

all shown properly in bios but nothing to be availabe in boot manager…

1 Like

i have the same problem(Batch 9) . At the moment i am trying to disable secure boot.

mine is from batch 9 as well. i tried to disable secure boot. nothing changed…

i have got it working. I changed my USB Drive to a newly Flashed and formated(fat32) USB 2.0 Drive and it just booted.

1 Like

YAY! I was going to suggest making a new USB boot key but I figured it might not be the issue since you had multiple OS installers and a DVD install… but glad it worked anyways!

#mee too. i followed the guide
Windows 11 Installation on the Framework Laptop DIY Edition - Framework Guides
and surprise works like a charm… so the problem was in front of the computer :wink:

1 Like

i used the microsoft “USB DVD-Downloadtool für Windows 7” which was a fault. using the media creator from microsoft directly did the job… sorry guys for bothering

LOL PEBKAC errror… JK… the whole purpose of forums like this is to learn and grow. and yes, the Windows media creation tools for win10 and win11 from Microsoft are the preferred / least error method!


I have the same issue after installing Debian I get the “Default boot device missing or boot failed”, I can install and boot into Windows fine and the driver of my ssd (WD sn850) is up to date.

None of my attempt lead to Debian booting from the SSD