[RESOLVED] No Audio via HDMI

I have the 11th gen in a Cooler Master case running Ubuntu. When I am connected to my TV via HDMI there is no sound. If I connect headphones the sound works with no issues. I have tried all the different outputs in the sound settings as well as alsamixer to make sure that nothing is muted but so far nothing has worked.

Any ideas on what I should try? Thank you for the help in advance.


Can you post a screenshot of the available sound options in your dropdown menu when connected to your TV?

Do you have another monitor with sound to test the HDMI output with? Can you also advise whether you are using the original gen 1 HDMI expansion card, or the Gen 3?

It is the gen 3 HDMI. I don’t have another monitor but the sound plays through the TV on my other Linux laptop works when I plug it in via HDMI.

Hi Nic,
Welcome to the forums,
can you list audio output via command line?

pacmd list-sinks

Also may we know what Ubuntu version you are using?

Ubuntu 22.04.2 LTS and below is the response. Let me know if you need anything else.

1 sink(s) available.

  • index: 4
    name: <alsa_output.pci-0000_00_1f.3.hdmi-surround>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: RUNNING
    suspend cause: (none)
    priority: 9030
    volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB, rear-left: 65536 / 100% / 0.00 dB, rear-right: 65536 / 100% / 0.00 dB, front-center: 65536 / 100% / 0.00 dB, lfe: 62895 / 96% / -1.07 dB
    balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 67.22 ms
    max request: 42 KiB
    max rewind: 42 KiB
    monitor source: 5
    sample spec: s16le 6ch 48000Hz
    channel map: front-left,front-right,rear-left,rear-right,front-center,lfe
    Surround 5.1
    used by: 1
    linked by: 1
    configured latency: 75.00 ms; range is 0.50 … 1837.50 ms
    card: 0 <alsa_card.pci-0000_00_1f.3>
    module: 7
    properties:
    alsa.resolution_bits = “16”
    device.api = “alsa”
    device.class = “sound”
    alsa.class = “generic”
    alsa.subclass = “generic-mix”
    alsa.name = “HDMI 0”
    alsa.id = “HDMI 0”
    alsa.subdevice = “0”
    alsa.subdevice_name = “subdevice #0
    alsa.device = “3”
    alsa.card = “0”
    alsa.card_name = “HDA Intel PCH”
    alsa.long_card_name = “HDA Intel PCH at 0x605d1c8000 irq 180”
    alsa.driver_name = “snd_hda_intel”
    device.bus_path = “pci-0000:00:1f.3”
    sysfs.path = “/devices/pci0000:00/0000:00:1f.3/sound/card0”
    device.bus = “pci”
    device.vendor.id = “8086”
    device.vendor.name = “Intel Corporation”
    device.product.id = “a0c8”
    device.product.name = “Tiger Lake-LP Smart Sound Technology Audio Controller”
    device.form_factor = “internal”
    device.string = “hdmi:0”
    device.buffering.buffer_size = “1058400”
    device.buffering.fragment_size = “529200”
    device.access_mode = “mmap+timer”
    device.profile.name = “hdmi-surround”
    device.profile.description = “Digital Surround 5.1 (HDMI)”
    device.description = “Built-in Audio Digital Surround 5.1 (HDMI)”
    module-udev-detect.discovered = “1”
    device.icon_name = “audio-card-pci”
    ports:
    hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
    properties:
    device.icon_name = “video-display”
    device.product.name = “55R635”
    active port:

Hey @Nic ,

Looks like it’s recognized properly, what’s the Make and model of the TV? perhaps there’s settings/menu on TV that need turning on?

Also try Fedora 39 live and Ubuntu 23 live, just to rule out any OS/kernel based issues.

I have a TCL series 6. I tried some different sound settings on the TV but that didn’t help. I also tried Fedora 39 live and have the same issue with that.

It’s not a problem with your TV.
The problem is on Linux and Intel 11thGen Processor and Hdmi Sound Output.
I have the same motherboard into Cooler Master case, or into the Frame.Work, i have HDMI output with a Windows 11 OS but not into Arch Linux with the last kernel and drivers.
On Linux Sound Output works with Jack or Bluetooth…

I hope some techs at Frame.Work could help us with a fix or a patch to apply.

So your HDMI audio works with windows? Have you tried any other Linux distro?

i tried Manjaro ARM and Ubuntu 22.04

SOLVED !!!
So i don’t know the commands on Ubuntu but i needed to do this steps on Arch Linux :

First even if my audio card use SND, i have to install SOF :
pacman -S sof-firmware
Then i had to create a file for adding an option during enable module :
nano /etc/modprobe.conf/myfile.conf
Adding this line :
options snd-intel-dspcfg dsp_driver=1
Then save and reboot the computer.

After the reboot i had to change again my sound parameters selecting the HDMI Output, try to put some sound and … it works !

Hope it will help on your Ubuntu

3 Likes

Ubuntu and debian equivalent would be

sudo apt install firmware-sof-signed

1 Like

Thank you both for the help but when I type in nano /etc/modprobe.conf/myfile.conf I get the below saying that the directory does not exist and it does not allow me to save any update.

You can then pass an argument in your grub.

Do
nano /etc/default/grub
I have this for GRUB_CMDLINE_LINUX_DEFAULT

loglevel=3 snd-intel-dspcfg.dsp_driver=3 quiet

The more important is that you have snd-intel-dspcfg.dsp_driver=1
Then save and grub-mkconfig -o /boot/grub/grub.cfg

After a reboot the Legacy HDA driver will be loaded and you wille be able to have audio on HDMI.

EDIT : After a reinstall for looking if it was right, i saw an error. it’s dsp_driver=3 (meaning using SOF whereas Legacy) I corrected it.

1 Like

This shows that the file is unwritable. I am guessing where it lists “quiet splash” is what needs to be updated?

hi @Nic ,
try sudo nano /etc/default/grub

edit then save

[SOLVED] @WERRY_Brice @Loell_Framework The sound works now. Thank you both so much for your help. I never would have figured this out on my own.

1 Like

Sorry, i forgot to tell you that this file is writable when you are in SUDO or ROOT state.

You can thank the Arch Linux Community, the documentation and support is really amazing.
I’ve made a topic there [SOLVED] No HDMI Audio - Fix works on PulseAudio not PipeWire / Newbie Corner / Arch Linux Forums

You can also mark this topic as solved.

1 Like