Odd charging behavior with Apple 30W charger and Framework 13 AMD 7640U

I read in USB-PD 15V mode issue - #10 by Kieran_Levin that the Framework 13 should be able to work with prettymuch any PD charger. But when I tried it with the 30W charger that came with my wife’s MacBook Air, the charging light would come on for a second or so, then turn off for about a minute, then repeat.

Windows also showed the battery as charging briefly while the light was on, then it reverted back to running on battery when the charging light went off.

I tried putting the laptop to sleep and leaving it connected to the charger for a while, but when I came back later, it was still doing the on/off behavior and the battery had dropped about 3%.

Does that post I linked to only apply to Intel models? If so, what are the requirements for AMD models?

1 Like

This same behavior occurs with a 30W Pixel Charger as well.

1 Like

Intentionally probably not but as long as the pd controllers on the amd are bugged effectively yes.

The circuitry is capable of charging from pretty much anything and you can trick it into doing so but the controllers are a little bugged. I hope they fix that with the next release.


Same with my 30W GaN charger by Anker (Anker 511/ Anker Nano 3). though, that one has been pretty flaky with other PD devices as well, but my previous laptop did charge just fine with it.

Same goes for cheaper/weaker chargers that came bundled with cheap phones and so on:
It refuses to charge with it, with the charging LED turning on just momentarily.

I sure hope any 5V source will be able to charge my framework in the future. a shitty 5V source should at least be able to charge it over night or something like that :slight_smile:

1 Like

With kickstarting that is allready possible, it working correctly without that is just a firmware fix away.

How does kickstarting work?

Plug in charger that works, plugin charger that doesn’t, unplug charger that works, other charger charges now.

One semi viable scenario where that’d actually help is if you had a small pd powerbank that you could use to kickstart charging with a currently incompatible-ish charger, otherwise you could just use the charger you kickstarted with instead XD.

The kickstarting thing is more helpful as a way to see what the hardware is actually capable of doing, it just needs the pd-firmware to be fixed now.


Nice, the kick starting trick even worked with a basic 5 volt 1 amp charger!

I also found a cheap Aukey 30W charger that seems to work fine without kickstarting.

Jup works with anything I tried, even if some needed a few attempts.

Some work, some don’t given what we know about the bug it mostly depends on how twitchy over-current protection is.

My baseus 30W ones work without kick-starting too but the 20W won’t

Ah, I’m having this issue with a 65W GaN charger from Anker as well, the little orange light will flash for a moment, then turn off. Maybe 95% of the time it works, but if it stops working, I’m not sure what to do to get it working again. Maybe kickstarting it is what i’ve been doing without realizing it… Restarting doesn’t solve it. I’m running manjaro on latest firmware.