Plug in Ethernet & WoL Gen 11 and Windows 11

Hi All,

Gen 11 laptop, Updated W10 to W11.

(Just for info this is one Gen 11 i7 that has megga power problems, like charge (BIOS battery) for 24 hours and next day it won’t power on, wait 24 hours and it does, but only with mains adapter, but this is not the topic as I say just for info)

I have been testing how to wake my desktop PC by logging into my Synology router from a remote location, and waking a PC on my home network (because the web OneNote does not seem to have all the info I save there)

I would not normally want a Laptop to be on WoL as apart from no need to do this, it would have to have the mains adapter connected all the time {some irony here with BIOS battery re-charging ? lol }

Looking at Laptop and W11 in Device Mangler neither mouse nor keyboard nor USB Ethernet adapter (UNI make) have the “Power Management” tab you would expect to see in properties. Not a framework problem but I assume a W11 one.

But USB NIC has setting for WoL in properties Advanced /Advanced such as
Wake on Magic Packet
Wake on Pattern Match

all set to “Enabled”

Also set a WoL looking setting in the UEFI BIOS (plan English BIOS makers please !! )

Then using WakeMeOnLAN (used before and works well) on local LAN i.e. not WoL via router I have mixed success with waking W11 on the Laptop.

Putting the FW in sleep mode with power light pulsing then (remote waking on local LAN) worked twice in succession. This was with the mains power attached. The light went from pulsing to solid.

Another point. As mouse (horrible pad thingy) and keyboard DON’T have the “Power Management” tab in properties then there is no way to disable their waking the Laptop and so apart from the power light there is no way to check if the WoL command from say WakeMeOnLAN actually worked as from sleep the Laptop will wake anyway. As touching a key just waksd it… Agghhh

(Ok ping Laptop from PC that has WoL program, but as yet to find why I can’t ping locally anyway)

Regardless trying the wake the FW again has failed every time…still with mains adapter (FW own adapter) and all settings for “Magic Packet” etc. enabled as before.


Rather long rambling post so please ask for more details as required.
I realise that this is a combined FW and W11 question.

Essentially has anyone managed to wake a FW Laptop from sleep, albeit with a USB Ethernet adapter?


After discovering that the Power Management (PM) tabs are not there for NIC or k/b or mouse {as they are in W10} (and all the registry edits don’t bring it back) you can see PM tab in the USB entries in Device Manager. I disabled (removed tick from the save power entry) from these and somehow and with mains adapter connected got the FW to wake from sleep.

Sorting out IF it really had woken (as pressing a key wakes it anyway) I used ping to a virtual Ethernet adapter I had installed to see if it was responding. It was.

Regardless I would like feedback from anyone who has tried WoL whether it worked or not !

I noticed a post on WoL and power problems, with any number of odd problem inc poorly soldered battery contacts with the FW 11th Gen machine. I will add a link to this post at some time.