[SOLVED] DIY AMD 13 - Power button only lights up while pressed


I just got my framework and installed RAM & SSD according to the guide.

However it wont power on even with charger connected. The power button only lights up while I press is, as soon as I release it it turns off. There are also no Post lights.

Before contacting support I just wanted to make sure I am not being dumb and missing something obvious…

Also should there be a light indicating charging? I get nothing no matter which charger I connect. I have tested the baseus 65W GaN charger I bought for the laptop as well as the steamdeck charger and a 45W Lenowo charger.


I’m thinking it might be an issue with the input cover itself. Is there a way to boot without it, just to test?

EDIT: Actually it definitely is… I guess I will contact support


Yikes. Definitely contact support and maybe even link them to this thread. This is the second or third time I’ve seen someone post a picture with this exact type of damage to that connector. Hopefully a root cause (defect, procedure issue, etc.) can be found.


Yeah it seems to be a relatively common issue.
The surprising thing is my input cover already came with the connector on that side affixed with double sided tape, which is supposed to be the fix.

Just FYI for anyone finding this thread later:

After disconnecting the input cover and disconnecting and reconnecting the battery I now also get post lights when I connect or disconnect the charger

I could also successfully boot using the power button on the main board located here:

Other than the input cover the laptop is working fine


Hey Mate,

I had exactly the same issue as you.
My power button never lighted up tho…
The touchpad got so hot it essentially burnt me as I freaked out trying to open it back up to unplug the battery.
I’m now concerned about both the battery and the motherboard notwithstanding the obviously damaged top section.

I am currently waiting in queue for a response from support

Not a great start day 1 :frowning:

1 Like

Hey Man,

that sucks, I totally know the feeling. We are in the same boat I guess.
I have also not heard back from support yet but it’s only been a little over a day.

For me th laptop is definetly working fine otherwise. As I wrote above you can test by reconnecting the battery and using the power button directly on the Mainboard.
Using an external keyboard and mouse I have already set up my laptop (firmware updates, OS install…) . So once I hopefully get a reply and replacement input cover it will be ready to go.

Fingers crossed support is not too overwhelmed at the moment.


From the looks of it, your cable seems to be properly aligned.
I will have a look on the website here and see if I can find any schematics.
Just curious about that part of the connector.

1 Like

Yeah the position looks good, also the input cover was delivered with the cable already affixed to it. As per step 9 of the guide it should have thus not been a worry:

If your Touchpad Cable already has double sided tape holding it in place on the Touchpad, you’re all set!

So maybe their procedure for fixing the cable has some issues or short circuits sometimes happens even if the cable is in the correct position for other reasons.

Looks like a few people are affected with the melting connector. Some people are also mentioned the same issue in this reddit thread.
Interesting that in the image posted there the cable also seems to be seated correctly and it melted in exactly the same spot.

I use my first post for this topic.

I’ve ordered my FW 13 AMD in batch 9. Since I’ve discovered this issue, I’ m feeling a little bit nervous. Is this a individual case or a series problem. Does anybody know if Framework support has a solution already?

Thanks a lot

These seem to be a few very isolated cases, maybe a few bad input modules with a manufacturing defect. Framework has send hundreds if not thousands of laptops and most of them work fine, Framework is also obviously aware of this as they have handled the support requests and exchanged the faulty input modules and I assume they’re trying to prevent this issue for future runs. I wouldn’t really worry about this. In the worst case, you might need to get an exchange, too.

1 Like

I agree. @Frank_Harnisch don’t think you have to worry. Its really hard to know how many units are affected, but I doubt its that many compared to total units shipped. People with issues are of course far more likely to post about it.

Also as mentioned by customers affected in previous batches (see reddit thread) it seems support is taking care of this really well by shipping a replacement input cover without fuss.

Only thing thats a bit frustrating that support is so backed up at the moment that them actually getting to the ticket takes a while.


I have now personally seen 4 either threads or comments regarding this same issue.
One of which, appears to be from batch 4, and appears to have had a reply that they will get a new input cover (edit - the reddit link you mention, they updated that thread with they are going to receive a new input cover)
If oldest tickets are being looked at first and any modification/update puts you back, surely we, being batch 3 would have had a response by now.
I understand they must be under the pump but based on their support thread I am quickly getting to the ‘oldest ticket’ territory being that I am 5 days in.

Yeah my request is now also almost 5 days old (sent Monday evening CET). It seems like the guy on reddit got a reply in 2 days.
It does not seem like they are processing the support requests in the order they are submitted, not even for the same issue. Hard not to be a bit annoyed about that

FYI: I am batch 4, but there is some overlap with when shipments arrive. Loos like you and me submitted the ticket almost at the same time

1 Like

This is what makes it difficult and where people get frustrated… I understand they are under the pump but it sucks we are getting left with nothing when we are following the guidelines and doing our part (not withstanding the fact we have paid decent money for an item that immediately was faulty)

I ran into the same issue, I was seeing that it was happening alot in batch 4 so I posted it in the batch 4 guild thread as well.

[Edit] If it helps at all I have a relatively new 7/23/2023 dated input cover, I was seeing some people are receiving older stock. It could just be an issue with the newly produced stock?
My own input cover:

I’ve already opened a support issue with Framework, but it’s interesting that I’m having a similar issue and was batch 4! Perhaps assembled on a Friday? :wink:

Only big difference is I don’t have any melted/burned connector under my keyboard and the button light does not go off when I release it. The laptop seems to stay on and the heatsink gets pretty hot, but the fan runs and the “case open” lights blink.

Mine did successfully turn on the first time, and made it to bios even though the connector melted that time as well, however it left the input cover completely unresponsive.

Have not turned it on since realizing incase its a larger issue than just a connector.

Weird. If the connector is not molten in could be something totally different, though of course the input cover might still be at fault. You could try turning it on without the input cover to confirm.

Mine is from 2021/12/27 - and (retro)fitted with the tape, so doesn’t look like its a certain batch. Probably just a relatively low failure rate across all batches and we were just unlucky.

I think it should be ok to attempt to power it on with the button on the mainboard, that has been working well for me.

FYI my ticket has now escalated to an rma for the input cover and battery (just in case it is damaged due to the heat)

Update on my own framework:

Powered on using the mainboard switch without the input cover plugged in, unable to boot, and I receive the post lights every time.

They’re reading out:
White, G, G, G, G, G, R, G, G, G, G, G, R, Orange, B, G, G, B, B, B, B

It’s also worth noting that the laptop requires being plugged in to attempt booting, but seemingly runs fine on battery, and has been blinking the no input cover lights unplugged since I attempted the test.

It’s also worth noting my input cover was not retrofitted with the tape.