RAM appears to be faulty after a BIOS upgrade (Win11)

Hi there,

I encountered an issue with one of my RAM sticks when updating my BIOS on my framework laptop. I have a DIY Framework 13 running a Core i5-1240P, and 2x16GB sticks of RAM. I noticed Framework published a BIOS version 3.08, an upgrade over my previous BIOS of version 3.05, so I upgraded it.

Following the first restart prompted by the installer, my laptop failed to turn on properly. The power button was lit up, but the screen was blank, and the side LEDs were powered off despite the laptop being plugged in to the wall. After a couple of failed attempts to reboot I noticed the LEDs flashed a specific color pattern, which the internet told me was a problem with the internal “DDR initialized OK” diagnosis. I tried using only one stick of RAM at a time, and it seems that one of the sticks will cause the laptop to fail to boot at all if it is plugged in, regardless of which slot I tried. The second stick of RAM works fine unless plugged in with the faulty stick. My BIOS appears to have otherwise updated successfully.

I’d just like to know if there is anything I can do about this bad stick? Is it just dead, or am I maybe doing something wrong?

Just wondering if anyone knows anything about this? If not I’ll just email Framework, but I wanted to ask the community before bothering them.

First thing I would do is check if there is faulty ram. Have you run https://www.memtest.org/ yet?

The RAM stick I’m concerned about doesn’t allow the laptop to post when connected to the mainboard, so I can’t run a memory test on it. After some experimenting with it I think it might have been corrupted by the BIOS update, is there any saving it?

ok, this don’t make sense. Brainstorming a bit about what you can try next:

  1. The stick is actually dead. You can try putting the RAM in another machine and test it there?

  2. Something up with CMOS settings on upgrade. Perhaps a motherboard reset could help.

  3. The BIOS changed the ram tolerances which caused it to stop working. Maybe they are different speeds or something and new BIOS don’t like that. Not sure, but if the BIOS is responsible, you can try downgrading the BIOS to see if the memory still works.

Thank you. I’ll try out your suggestions and see what happens…

Okay, so I tried plugging in the stick into a friend’s laptop, and it worked. I then plugged the stick in question back into my laptop, and it works now?? Not sure why, maybe it just needed a different motherboard to reset. Either way, works like normal again. Thanks for your help!

1 Like

That be crazy. Super-curious what memory test would return.

I ran memtest anyway just to check out what’d happen, and weirdly enough, it passed with no issues whatsoever, if I read the results correctly. I attached the result if you’re curious.
I truly have no clue what happened, just glad it works :sweat_smile: