[RESOLVED] Even lower screen brightness?

I use my laptop as a TV at night when I go to sleep, but the lowest brightness is still too bright for my wife who is trying to sleep.
Is there a way to get even lower brightness than the lowest option currently available?

I am on Fedora 37, but I can entertain switching to something else if it makes it easier.

1 Like

I had the same needs and was previously using the script in this thread to reduces screen brightness to minimum.

Recently I discovered and started using Light. I set some shortcuts using the alt key with the screen brightness keys which works well for me. Pictured is my minimum brightness shortcut and brightness step up shortcut.

An increase brightness value of 0.18 gives me 4 steps between absolute minimum (0.1 in Light) and minimum brightness using keyboard controls (1.0 in Light).

You can also turn the backlight off completely if you keep stepping the brightness down or set it to zero.


It’s wild as I pride myself on knowing of programs like this, but this one is a new discovery - I like it! Bookmarked. :slight_smile:

1 Like

I am using the settings below in i3 and sway config. The lowest brightness is no problem.

# Brightness size 
set $brightness_size 2
# Framework Laptop F7: XF86MonBrightnessDown
# The --min-value option is important to prevent the complete darkness.
bindsym XF86MonBrightnessDown exec "brightnessctl --device intel_backlight --min-value=1 set $brightness_size%-"
# Framework Laptop F8: XF86MonBrightnessUp
bindsym XF86MonBrightnessUp exec "brightnessctl --device intel_backlight set $brightness_size%+"

Nicely done!

1 Like

I had the issue too. The ubuntu mate desktop goes by 5% increment. So I needed to go below 1%
Bit now I have a mate screen to correct the mirror effect and it remove some light…solving both problems. We definitely need a mate screen option :grin:

As a note, I am using a matte screen protector. You can see Matte screen protector for details.


I installed light and was not able to get it to lower the brightness lower than the default GUI tools. At the lowest setting in the GUI tools, light reported brightness at 0.78. Lowering it to 0.01 did not have any noticeable effect.

@Matt_Hartley could we reopen this ticket or test that the solution works on AMD boards? I am not able to get any lower brightness using light on my AMD 7640.

These are the available devices on my system:

$ light -L
Listing device targets:

I see that there may be some issues around setting backlighting on amdgpu_bl1 here: AMDGPU Backlight issues / Laptop Issues / Arch Linux Forums

Test brightness on a tested/supported distro. Live usb works. Make sure it’s just the distro. We use it just fine on Ubuntu 22.04 and Fedora 39.

Also I assume you’re on 3.03 bios update?

On Arch with 6.6.1-arch1-1 both light and brightnessctl reach the same value of 0 and brightness (darkness :thinking:) for me (AMD 7640U).

brightnessctl outputs:

Device 'amdgpu_bl1' of class 'backlight':
	Current brightness: 0 (0%)
	Max brightness: 255

My keybinding in sway is as follows:

bindsym XF86MonBrightnessDown exec brightnessctl set 5%-
bindsym XF86MonBrightnessUp exec brightnessctl set +5%

Test brightness on a tested/supported distro. Live usb works. Make sure it’s just the distro. We use it just fine on Ubuntu 22.04 and Fedora 39.

Also I assume you’re on 3.03 bios update?

I am on BIOS 3.03 and using Fedora 39.

Using GUI tools (and the hardware buttons) I am able to control the brightness from 100 down to 0.78.

Using light I am able to set brightness from 100 down to 0.00, but there is no visual difference between 0.00 and 0.78.

At 0.00, I expect the backlight to be off, but it is still on (and still too bright).

@Matt_Hartley, OP reports that they are able to turn the backlight off completely using light-- are you able to reproduce this?

Don’t have the cycles to install light and test against this today on Fedora. However, the moment we deviate from a default config, all sorts of new challenges present themselves in trying to replicate. Especially true outside of vetted/supported distros.

Light is not tested whatsoever and is a community support application. Using brightnessctl is fine and would be expected to work correctly, but op is using Arch. So hard to say.

They need to test against Fedora.

I’m not OP, just sharing my experience under Arch. light and brightnessctl both work fine and are able to set the same brightness values with matching results in light output. There might be differences between AMD and Intel in backlight behaviour.
I remember my Intel Dell XPS being able to turn it off completely as well just by setting brightness to 0 regardless of used tool. It was relatively big step from lowest to off on that machine, so probably not helpful for @gaben.

Appreciate you chiming in with your experiences, always good to get another perspective.

11th gen and AMD Ryzen 7040 Series configs both “work out of the box” with the slider in Fedora and Ubuntu, plus on the keyboard. 12th and 13th gen require module_blacklist=hid_sensor_hub as described in the guides.

Same here.
AMD 7640 on linux mint, but the minimum brightness at 0% is also way to bright for my convenience in the evening.
Using it in complete darkness (such as when camping, as I quite often do) will be impossible.

Using redshift helps a bit, but having a wider range of the brightness itself would be great!

Appreciate the feedback, using Redshift may be the best option in this situation.