[SOLVED] External HDMI monitor not detected

I recently received my Framework 13 13th gen intel.
I am running linux Ubuntu 22.04 with the XFCE windows manager.
I try to connect any external monitor via the HDMI port and it sometimes is detected, and sometimes is not.
When detected, I cannot mirror displays.
I have tried putting the HDMI card in various bays with no change
I am at a loss as to how to proceed.
Any help would be greatly appreciated.

this is the output of xrandr
I don’t understand why the montior is seen as DP and not HDMI ??

$ xrandr -q
Screen 0: minimum 320 x 200, current 1579 x 1052, maximum 16384 x 16384
eDP-1 connected primary 1580x1053+0+0 (normal left inverted right x axis y axis) 285mm x 190mm
   2256x1504     60.00*+  48.00  
   1920x1440     60.00  
   1856x1392     60.00  
   1792x1344     60.00  
   2048x1152     60.00  
   1920x1200     60.00  
   1920x1080     60.00  
   1600x1200     60.00  
   1680x1050     60.00  
   1400x1050     60.00  
   1600x900      60.00  
   1280x1024     60.00  
   1400x900      60.00  
   1280x960      60.00  
   1440x810      60.00  
   1368x768      60.00  
   1280x800      60.00  
   1280x720      60.00  
   1024x768      60.00  
   960x720       60.00  
   928x696       60.00  
   896x672       60.00  
   1024x576      60.00  
   960x600       60.00  
   960x540       60.00  
   800x600       60.00  
   840x525       60.00  
   864x486       60.00  
   700x525       60.00  
   800x450       60.00  
   640x512       60.00  
   700x450       60.00  
   640x480       60.00  
   720x405       60.00  
   684x384       60.00  
   640x360       60.00  
   512x384       60.00  
   512x288       60.00  
   480x270       60.00  
   400x300       60.00  
   432x243       60.00  
   320x240       60.00  
   360x202       59.99  
   320x180       59.99  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected 1920x1200+1579+11 (normal left inverted right x axis y axis) 0mm x 0mm
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
  1920x1200 (0x75) 154.000MHz +HSync -VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock  74.04KHz
        v: height 1200 start 1203 end 1209 total 1235           clock  59.95Hz

I would send a message to support if you haven’t already, there is a chance that you have a bad HDMI card.

As suggested above, please open a support ticket. Please indicate if you’re using a hub or dock or similar to connect the device.

If this is a direct connection to a hdmi expansion card, please indicate this as well.

Framework support responded quickly with a procedure to test. It turns out that the problem lies in the XFCE window manger used by various Linux distros.

I was able to work around the issue, but am now considering changing distros to avoid this problem altogether.

Thanks again for you support!


Glad we have a solution for you. :slight_smile: