[RESPONDED] Flaky usb port

I have a gen 11 laptop 13 running Ubuntu 23.04. Many moons ago I had issues with the USB port being flaky with devices not being recognized all the time. Eventually the motherboard was replaced and that seemed to fix the issue.
Skip forward to today. I have a thumb drive that I was trying to connect but in the majority of cases it would not. The drive has a light on it that should light up when the drive is plugged in. Most of the time it doesn’t. I tried with a USB-A adapter on the top left expansion bay and also on the bottom right bay (different adapter). The behaviour is the same in both cases.
In the olden days, one solution was to sort of half way insert the USB device and then, once power seemed to be up, insert it all the way. This trick still works a lot of times (but not always).
The same thumb drive is recognized by my Gen12 laptop without any issues.
The Gen 11 laptop runs BIOS 3.10, the Gen 12 laptop runs BIOS 3.05
Was a fix for this issue ever found? It seemed to happen to many people.
Would BIOS upgrade fix this?
Is there a post explaining how to upgrade the BIOS? I did run across a note that BIOS 3.19 was to come shortly …
I do not want to upgrade the BIOS unless the USB port issue has been fixed. I guess if it is a fundamental hardware problem I will have to live with it as this computer is well out of warranty.

Hi @Jens,

Let’s get you into a support ticket for triage.

Thank you Matt … let me confirm that a) the computer is long out of warranty and b) the main board was already replaced once. I tried all the expansion bays with all the USB-A adapters I have when the issue first arose.
I would think that a BIOS upgrade is about the only fix that would make sense but I am open to any suggestions.
Have you opened the ticket or do you want me to open it?

Yeah, I’d need logs to focus on what I suspect may be going on (port specifically), please open that ticket and link to this post directly.