Ryzen 7040 black screen no booting

Hello I got the laptop delivered today, I followed the guide and inserted the Ram and the ssd etc… But when I try to turn on the laptop the screen remains black and I get a code sequence after a while.

RAM: 2x32 Crusial 5200 CT2K32G52C42S5
ssd: WD_BLACK SN770 Nvme 2TB

Sequence code: 12 green, orange, BGBGGGG

I already tried with each RAM module independently in each different slot, and also with the two of them swapped. Tried without the Nvme too and always get same result with the same sequence. I can’t find any documentation for the Ryzen 7040 for the sequence specially the post code since the first 12 blinks where all green.

1 Like

There have been several reports of individuals not being able to boot with 5200 mhz ram. You should get 5600 mhz RAM as the vast majority of users with that RAM are able to get it to boot.

1 Like

Wow, I just saw this thread AMD RAM issue - Community Support - Framework Community, I bought it a long time ago so I don’t think I can return it at this point. Thank you either way

If you bought it with Amazon, you may be able to request a refund although, there may be a restocking fee.

I stumbled across this thread Post code bits meaning which has a link to a github file with code definitions but cannot confirm that it also applies to the Ryzen mainboards.

I am having the exact same issue but I am using a 2x16GB 5600 MT/s kit (Crucial CT12K16G56C46S5). Even tried a single 4800 MT/s SODIMM. All 12 system checks are green followed by a 0xA3 post code (BGBGGGBB). I would still contact support with your post code before trying to return your RAM since getting a 5600 MT/s kit isn’t guaranteed to work.

Or if you do end up returning the RAM then get something on the official support list. Reading around there have been reports of the kit I got working. But probably safer to get something framework has verified to be compatible.

Same led error code here. I started with the official RAM I bought with my 7040 series DIY and added a gskills sodimm only to learn the compatibility likely isn’t going to include that model.
Unfortunately mine still won’t post even using just the framework sodimm that it came with, in either slot. No video feed with the hdmi or DisplayPort expansion cards using external display either.
Ticket is in and I’ll report on any solution/recommended steps cs suggest.

Found this post including the breakdown of the led post codes: Post code bits meaning
Where BGBGGGBB translates to 1010001.

I finally got it to post something on the display. Looks like even though it flashed green for the DDR check (11th LED flashes green as per My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on), the RAM needs to be reseated. I got mine to work in slot 1 (instead of the expected slot 0), though your mileage may vary so keep trying both.

I read another post suggesting this issue is intermittent and may return requiring reboots until it works or reinserting the sodimm (if it’s anything to do with the memory at all).

From the FW guide:
“If your power button lights up, but you don’t see the screen come on, and the side LEDs are solid

On the first boot after installing new memory, the side LEDs will stay green for a period of time (up to a couple of minutes) to do memory training. If the LEDs remain a solid color for more than five minutes, try powering off and reseating the memory modules or trying them out one at a time in each memory socket.”

Appears my issue is due to some bad pins on the slot 0 SODIMM socket. Got into contact with support and was taking pictures when I noticed pins 4 and 8 were recessed further than the others. Tried booting with memory only installed in slot 1 and got the system to post. Verified both modules work just to be sure.

I’m not sure when the pins got damaged but did noticed that the sticker identifying the slot was not attached to the board when I received it. Should have probably inspected the pins then.

Little annoyed to because I tested with one module only but only tested in slot 0 apparently.

Hopefully you all get to the bottom of your issues as well.

1 Like

Glad you made progress @spdrpig. I should inspect my pins on slot 0 as well. I’m trying to get my second sodimm (GSkill 16GB DDR5-5600 model: F5-5600S4040A16GX1-RS) to train rn and if it doesn’t work this round, I’ll do the needful and inspect the slot more closely.

Thanks for reporting your findings.

As to my original problem:
I can report that the system has been booting up fine and no further issues with the original framework memory module using slot 1.

Confirmed. I have a bent pin too @spdrpig. DIMM slot 0.

Update 2:
Well I didn’t think that was going to work, but I was able to gently move the pin back into the guide. It wasn’t pretty but apparently it made contact and boots now! For any who would attempt to do this: I recommend you contact support to see about replacing it first and if they care if you try repairing it yourself.

In other news, these GSkill sodium’s will work with the Framework 13” Ryzen 5 7640U:

Update 3:
Support got back to me. I’m going to run memtest for a while and see if any issues crop up. I asked support to leave my ticket open until I’ve had enough passes to feel confident that I won’t need an RMA at this time.

1 Like

It’s worth noting that if anyone needs to reset the BIOS to defaults on a Framework 13” Ryzen laptop, these are the steps support offered to me as one of the troubleshooting steps:

If the issue still persist. please try to perform a reset.
-Plug in the system to AC.
-Remove the Input Cover.
-Press the chassis open switch in the center of the Mainboard 10 times, you must press it slowly, so press for 2 seconds. Release, wait for the red blink on the Mainboard LEDs. repeat.
-Press the power button to boot the system
-BIOS settings will be reset to defaults.

I couldn’t find this info anywhere and I’m sure someone in the future will want to know how.