[SOLVED] Bios 3.17 and dual boot wifi

I have an 11th gen 13" laptop with Windows11 and Ubuntu23.04 installed. Grub handles the dual boot config. I updated to BIOS 3.17 without difficulty but I note a new problem.

When I hibernate Windows then my Linux WiFi does not work. No hardware is found. I can plug into cabled network when at home and that usually gets wifi back. If Windows is shut down (not hibernated) this problem does not occur.

I have not had this problem in previous BIOS updates. I’m frankly mystified. Anyone notice such an issue in dual booting 11th gens?

< david

That’s completely normal with dual-booting with Windows, even with other PCs/Laptops. Windows somehow takes “ownership” of the Wifi card and keeps it assigned to itself until you do a cold shutdown/reboot.

You might have to fiddle with Windows settings to fix the issue, disable fast boot, fiddle with the energy options of the Wifi chip. I’m unfortunately not sure about the exact setting that would fix this behaviour.

More often than not, the issue is that the drivers on Linux cannot handle reinitializing the card once it’s been set up the first time. It often turns out that a soft reset does not also reset peripheral devices, which leaves them in an unclean state when you switch operating systems.

After all, the wifi card is running its own operating system… and often during a soft reset, it keeps running and its controlling host disappears and has to come back not knowing what state the card is in.

There is no assignment of ownership or any (possibly nefarious) means of intentionally breaking it. :slight_smile:

1 Like

Thank you both for your replies. I have tested two proposed solutions and one of them worked!

I first tested whether turning off fast boot might make a change. Suffice to say: no.

I found a suggestion to turn off WiFi in Windows prior to hibernating. That did it! I am satisfied and can easily incorporate that into my processes when I want to hibernate Windows and go to Linux.

All I had to do before hibernation was turn off Wifi in Windows. Very pleased to understand what is going on and, even better, to have found and confirmed a solution.

I hope this helps anyone else in a similar situation.

PS: I am really a fan of Framework and its community, fwiw :wink:


Marking resolved. Thanks :slight_smile:

1 Like