[SOLVED] Cannot remap keys

I have defined a keyboard layout in QMK and uploaded it to my keyboard. I added a few combos and redefined the capslock key. That’s all working great, and you can find the firmeware here

Now I am trying to remove the mapping for a few keys, so I changed the KC_ESC to KC_NO to encourage me to use the new combo. I built and uploaded the firmware the same way, but the escape key still works. I tried remapping the 1 key to be a 2, but it still types a 1.

Getting frustrated, I opened https://keyboard.frame.work and it shows my escape key blank and my 1 key as a 2! But when I try them in the keyboard tester the keys still work.

Any ideas why I seem to no longer be able to remap keys?

Did you clear the EEPROM after loading your new firmware? If you don’t do that, you can get problems. You can have previous keymaps remaining or corrupted parts of keymaps.

Clearing the EEPROM using Via (click to show)

Resetting the keyboard to factory default / clearing persistent memory.
This will erase any changes you’ve made in Via (keyboard.frame.work). If this is your first time using the site, you’ll have to authorize connection to your keyboard first.

  1. Go to keyboard.frame.work.
  2. Select a key to remap by clicking on it, the key will start to slowly flash
  3. In the key selection area below, click on the Special section
  4. Select the Any keycode, found at the bottom
  5. Enter QK_CLEAR_EEPROM and press Confirm
  6. On the keyboard, press the key you just remapped
  7. Reload keyboard.frame.work for it to show the change

You can also use Framework’s qmk_hid tool to do it by commandline github.com/FrameworkComputer/qmk_hid

Clearing the EEPROM seems to be working. I set it up initially using Via as you instructed, just to get things working again. Now that it’s working I was able to bind QK_BOOT and EE_CLR to keys in the Fn layer to make it easier for next time. Thank you!