[SOLVED] EndeavourOS KDE Plasma Fresh Install No Good


TL;DR EndeavourOS fresh install with KDE does not work.

I have been using Arch for years. The last time I did an install was a little while ago on my T440p and I did it manually. I installed KDE and it has been working great ever since. I got a Framework laptop today and decided to use EndeavourOS to install Arch and KDE because I just wanted to get up and running without much hassle. I have tried installing it 5 times now and every time once I boot into the new install nothing works. I cannot click on anything but the start menu and corresponding power options. None of the actual entries are clickable. The wallpaper, desktop and associated windows all flash whenever I move my mouse or click anything. The toolbar is completely broken and the icons are all weird. I cannot click any of the settings options in the settings menu. The only things that are functional are the Endeavour welcome dialog and the start menu options for shutdown. I have tried reinstalling a few times like I said and also tried switching the display manager to lightdm. If I leave it for about 5 minutes, it eventually crashes and restarts.

The previous release of EndeavourOS installer, Neo, also has this issue.
Ubuntu seems to work fine.
Kubuntu also works fine.

Here is a video showing what I mean

Solved my own issue. The fix for anyone else who runs into this is to remove the xf86-video-Intel driver.


Thanks a lot for the note, minimized the bad first experience with my new Framework Laptop :slight_smile:

It worked thank you! I don’t own a framework laptop, but I’m so glad I came across this solution. Now I can continue my EndeavourOS install.

1 Like

How did you accomplish this without raising a terminal? Did you use the installation media?

*EDIT: I found a funny workaround which is to insert a USB stick, then, when the Dolphin window pops up, right-click and select “open terminal here.”

@Aidan sorry, I just noticed your post. I am glad you got it working. I think I switched to a different tty with CTRL+ALT+F2 or F3 or or whatever was available.