[SOLVED] FrameWork 12th Gen Intel Hard Freezing in Fedora 37 and Windows 11

Hello, I have bought a Framework refurbished Intel i7-1260P laptop. Since I received it last thursday, it has given me nothing but troubles.
OS: Windows 11 & Fedora 37
Description of Problem: It usually happens after installing the driver pack on windows 11 or the initial update within Fedora.
I am about 20 emails deep within support, I have gone through 4 tech support agents who are now telling me the same thing. Use different ram and different SSD, which I have done both of. The freezing issue still has occurred, I have done everything from resetting the laptop with the RTC battery and disconnecting the main battery to taking out every expansion card that I have. Which are 3 x USB-C and 1 x USB-A.
I am getting nowhere with tech support, not even a RMA request. Just a warning to everyone on this forum, do not buy their refurbs as they are not properly tested with a benchmark for stability before shipping out.
I really wanted to love this laptop, but with the instability that this machine has I simply cannot recommend it to anyone right now.

1 Like

@Pat_Kilo I would urge you to stay patient. 20 emails deep is still normal for Framework’s L1 support (it was the same for me). They are filtering out obvious problems. At some point the issue will be escalated, and then if they think it’s hardware they’ll try to find if it is a fault or a CID (customer inflicted damage), and in case of a fault they can propose a RMA.
I’m pretty sure that the reason why they cannot connect you to L2 support from the begining, is that there are thousands of tickets and not as many higher level support staff.
Of course it could be better (I understand you, in my case too there was some amount of redundancy between questions from the staff), but a little bit more patience would help you keep them on your side until resolution!

1 Like

I understand with being patient, but at what point does asking the same questions about using a different stick of ram or ssd do to remediate the issue?
It doesn’t, it just wastes time.
I have tried four different sticks of ram that all freeze on the machine. Three different SSD’s, one PCI-E 4.0 the SN770 then a Samsung 960 eve and a silicon power SU512GBP34A80M28AB which all froze on my machine. I even replace the thermal paste on the machine with some Arctic silver 5.

@Pat_Kilo I’d say: I’m not Support and I don’t know their activities, but there is the possibility that they are quite busy (possibly because of the public unveiling event tomorrow), and that may be why you are stagnating at L1 support.
Maybe it’s not at all about what they are asking right now, but more if the right persons to make a thorough diagnostic are available enough right now, and maybe they are not.
IIRC, they are still a sub-50 people company!

(By the way, I don’t know if or how this is relevant, but it may help to show them photos when you try some RAM sticks etc (this is what I did), because it allows them to check if the components are properly seated. That can increase their confidence that RAM is not the problem, for example.)

Edit: by the way, I keep telling you are at L1, but maybe you were already in contact with higher support. I just don’t know, I don’t have the details.

1 Like

@Pat_Kilo I’ve reviewed your ticket thread and this is pretty standard troubleshooting to isolate the potential issue (10 responses over 3 days from our Support team, not including the auto-responder). As of 5:43am PDT this morning, our team reached out to you to let you know that we’ll be replacing the mainboard (we’re just waiting for you to confirm your shipping address for the replacement), but being transparent, I’m not confident that will resolve your issue as it could be one of your components purchased elsewhere (SSD/RAM). If after receipt of the replacement mainboard, you experience the same issues, you will know for sure that you will need to contact the other retailer where that equipment was purchased from or contact the manufacturer for warranty information (as it was not purchased from us).

As to why you were getting different agents responding, this was due to the times in which you were responding to our responses. You were crossing over multiple shifts and we have a round-robin system that pulls open tickets into the queue for triage. Tickets do not stay with one agent as that would delay response time given days off and hours of operation for a single agent. I do see a little redundancy that can be trimmed in responses, which will be addressed, but in general, the questions asked were to isolate whether it was either an OS, mainboard, or RAM/SSD issue (purchased elsewhere).

When you receive the replacement mainboard, please let us know if that does indeed solve the issue. This will help us update our troubleshooting steps and improve support flows.



Update 3/27: I replaced the motherboard with the new one that Framework have sent me. I did a sector by sector format of my SN770 2TB SSD which had no write errors.
After using memtest86, the crucial ram passed all test.
The new motherboard is working great, it did not have the thermal issues that the previous board had. I am very impressed with the speed of the replacement board that was sent out by Framework to fix the issue I was having.
At the time there was no resolution when I posted the initial message.
One suggestion I would put in is use a benchmark program like Cinebench or Passmark to make sure those boards can pass a sustained load for 20 - 30+ minutes.
I would hate to have someone have a similar experience as I did. Framework is doing great work, there are literally no other companies doing what you are trying to do. I look forward to seeing what else you create.


Delighted to hear this is resolved, also appreciate the feedback on benchmarking.