Hard freezing on Windows 11 on 12th gen system

I’m not sure if this is completely related, but I got the 12th gen framework a couple of days ago, and tried installing windows 11 with similar results. It randomly freezes with no way to consistently trigger it.
For reference these are the specs:
CPU: Intel® Core™ i7-1260P
Operating System: Windows 11 Home (Download)
Memory: 16GB (2 x 8GB) DDR4-3200
Storage: 1TB - WD_BLACK™ SN750 NVMe™
I have tried reseating the ssd and ram.
Removing one stick of ram.
Swapping the slots the ram is installed in.
Reinstalling Windows 11.
Installing the 12 gen drivers.
Installing Fedora 36 with similar results.
Attempted to update the firmware for the ssd, but the update utility claims the most up to date version is installed.
Running a SMART test with the same utility, which came back with no issues found.
I have also tried swapping the ssd, but unfortunately I don’t have any drives without data on them that I am willing to risk, so this last step I couldn’t test extensively.
During all of this the computer would randomly freeze with the only solution being a force shutdown. It would crash anywhere between 5 to 30 minutes. We have two 11th gen framework laptops with none of these issues.


Yes - we are having the same problems, but nowhere as frequent - it’s happened maybe 2-3 times in total in the last 2 weeks.

32GB RAM (2x16)
Windows 11 Pro (fresh install)
Storage: Crucial P5 Plus 500GB M.2 NVMe PCIe SSD/Solid State Drive

I was experiencing the same issues as both of you. I seem to have fixed my issues by removing the display port expansion module. Not sure if either one of you are using a displayport module, but just made an account to see if I could save you guys the trouble if this is in fact what is happening to you.

1 Like

Similar problem. Windows 11 on 12th Gen Intel.

Thought it might have been the SSD but swapped it out with another SSD that random freezes continued. Replacement from Amazon had the same problems.

In event viewer I was having a lot of errors with stornvme event id 11.

I have run memtest86 which passed. prime95 shutdown unexpectedly but didn’t detect any errors while running.

Not sure if that may help.
But on linux I had some freezes from time to time.
I have tried quite some stuff.
Now I am very stable :
Deactivated the efficient cores feom bios (one left)
Running linux kernel 5.15 shipped with ubuntu 22.04lts(not the latest 5.18 …)

My belive is that 12th gen is not yet ready for prime time…

I jave samsung ssd980

@Ryan_Z - I am using the displayport module - will remove it and see if it helps - thanks for the idea.

I have seen occasional lockups on mine, but they seem to be video-related only. The image on the screen freezes, but audio continues playing and I can even pause and unpause playing music still, for example, so it seems like the rest of the system is responsive and the GPU has just frozen. The only resolution I know of is to power it off and back on.

What happens if you have your Power button configured to sleep (in Windows)…and see if a sleep / wake cycle would unfreeze the GUI? Or maybe even hibernate (as it would power off and POST)? Trying to see if there’s a temporary workaround where there’s no work / data lost.

That sounds like a different lock to mine - mine is a hard freeze - the audio stays on the same ‘note’ (for want of a better word) and everything locks - there is nothing new happening on the screen (it’s completely frozen), nothing responds, there is no activity at all.

We have to do a hard power-off to recover (press power for 20 seconds).

As an update:
We’ve tested for several hours now without the DP card in, and the freezes have not … yet… re-occured.

Annoyingly, we also did a number of driver updates using the Intel Driver Support and an SSD firmware upgrade, so I can’t 100% definitively say it’s the DP card, but it seems likely, given the report above.

I’m tempted to try the Beta firmware for the DP, but it could also be a card that is bad.

I went back and forth with the framework support for a couple of days. Unfortunately I was never able to get my system stable for more than 30 minutes. Removing the expansion cards did not resolve the issue. My belief is that it’s a firmware issue for the bios or something, but I don’t know for certain. I ended up just returning the laptop for a refund. I didn’t think to have something with audio playing when it crashed.

If it helps any, I have had a very similar freeze on my Win11 12thGen. As near as I could determine it had something to do with the DP expansion card. I went through two different cards, one sent to me by Framework support, and both would cause my laptop to freeze. I also tried a beta FW update which didn’t work and caused other issues but to be clear the FW wasn’t meant to fix my problem, just thought I’d give it a try. Also, as someone noted, if there was audio playing the laptop would freeze and get stuck on a single tone.

For the time being, I do not require DisplayPort so I’ve move on hoping that Framework will fix the issue. My HDMI card still works fine and there are alternatives such as a docking station with DP or a USB-C to DP cable.

I would like to point out though, if this were any other laptop and the DP port went bad I’d be out of luck. At least with Framework I can remove the port and replace it with something else or fix it completely when the issue is resolved. This is why I’m still a big fan of Framework.

Thanks @James_Adams - this feels like the exact same as for us - thus far we’ve had no futher hangs since the DP card has been removed.

We are intending to just go USB-C on all ports and having a small portable USB-C Hub to provide USB-A, HDMI and DP.

Quick update to this in case anyone googles it later.

We seemingly had a ‘bad’ DP card, as a brand new one in the machine has not generated any lockups or crashes as yet…

How many hours with the new card so far?

I just got my 12th gen DIY with Win 11 on it, and I’ve also been experiencing hard freezes where absolutely nothing would be responsive, and I’d have to hold the power off button until it turned off. I haven’t been listening to any music, so I can’t tell if the sound was still active or not. Curiously enough, I did also have a DP module in. I’ve taken that out, so we’ll see if that changes anything.

I don’t know if this is a separate issue or not, but my computer also frequently powers off when I’m not using it. In that I’ll close the lid for the evening and the next day I have to boot up from a powered off state and all programs are closed.

This part is not expected.

Yeah, I don’t love that it’s doing it. It’s only happening when I’m not using it, so I can’t tell when or what’s causing it. Not sure if it’s related to the same issue in this thread.

There are some on-going reports / threads on the sudden / unexpected shutdown:

1 Like

Interestingly the same screen freeze thing just happened to me again, but this time with it plugged in to the TB4 dock. The system is still working and everything on the other 2 monitors is usable, and I was able to use win+left to move the window off the frozen laptop screen to another monitor. Now I’m staring at the frozen image on the laptop screen but everything else is working. I can adjust brightness on that screen with the laptop keyboard.

UPDATE: I used the display extend button (F9) to change it from “Extend” to “Second screen only” and then back to “Extend” and it came right back to life. Weird as hell.