[SOLVED] Jack socket not working, headphone is not detected

Hello there. I have already solved this issue, hence why I create the topic with a [solved] tag, but I wanted to share my experience with other Framework users so they don’t make the same mistakes as me.

My problem was that the Jack socket on my Framework laptop simply refused to work. My headphones were not detected, no matter what I tried. No pilot or Windows update could solve the problem.

And the solution was just that… my headphone was not correctly plugged in the socket. The Framework laptop opposes an unusual resistance to plugging the jack connector, and I was afraid I would only damage my computer if I applied more force. As it turned out, applying more force allowed the jack connector to fully plug into the socket.

If you are encountering the same problem, check that your Jack connector is fully plugged in before bothering technical support and opening up your laptop :stuck_out_tongue:

Here are reference picture for a correct plug and an incorrect plug:

Lots of thanks to the Framework support team for their patience and the dozens of messages we exchanged over such a stupid mistake on my part!