Star Citizen?

Hello everyone. Looking for anyone who’s tried out Star Citizen on the Framework 16. I’d love to watch or read a review on it, or even just a “yes it works smoothly” or “it’s so bad it’s impossible to play” or anything in between.

I know the specs say it’ll run, but does anyone have first-hand knowledge of how Star Citizen runs on the Framework 16 with the dGPU? How about with the on-chip GPU?

Looking forward to replies. Thanks.

Did not manage to install under linux … well, the lug helper is not working kind of.

Star Citizen is very CPU bound. I was able to do 4k@60fps on a rx580 8GB without issue, which is similar in spec to the dGPU of the Framework. You should be more concerned if the CPU can handle it.

It’s easier to install it through steam, that’s how I did it on my steam deck. Here’s a post that describes one way to install it. In a version of proton, support was added for manually specifiying the game’s name in the launch params that would automatically handle the EAC stuff for you… however I can’t find a reference to that anymore. It was something like game-name=starcitizen %command%

Assuming you have 32Gb of ram, I would assume it runs fine.

It hadn’t occurred to me to attempt this experiment, but now I’m going to have to…

1 Like

If it runs on a i7 7800K cpu, it will run on the 7840HS…

So - tried to install it under Steam, and it didn’t work. Again … sigh
Followed several different howto’s …

Did you try different versions of proton?

I installed it and it runs pretty smooth, looks like medium settings. It has a weird mouse issue where it slams you looking at your feet constantly so I haven’t played it much or tried to resolve that issue. Can’t even leave my cabin with the mouse issue. This game kind of lost the magic it had back in 2013.

Ryzen 9 7940HS, dGPU, 64G ram, Arch Linux.
Installed through Lutris.

OK. I reinstalled winehq completely from scratch etc. and now it did install.
So - FYI - the installation of the entire star citizen took around 20minutes (lol).
Under Windows it takes at least an hour …
But unable to start the game itself …

Thanks for the replies everyone. I’m glad to hear it at least runs, @jared_kidd. The mouse issue is probably some weird wine thing that can be worked around. But I plan on running it on a windows vm anyways, so that will likely not be an issue.

Thanks for your efforts as well @Jorg_Mertin.

@RandomRanger you were able to run SC on your steamdeck? That sounds tough lol.

Ok. Well, once the installer was installed, I did go out of Lutris - and added RSI Launcher as external Game to Steam, and force latest stable Vulkan.
And it works!
I admit through the dock on a 4K screen it was a lil slugish. Will test tonight without docker/external screen. Bet it will be better in 2K mode.
Here just after I quit the game:

The chip is actually quite capable of running Star Citizen at ~30fps, however it doesn’t have enough ram to account for the ~23GB Star Citizen wants, let alone share that with the gpu, so the framerate goes from 30fps → 0 → 30 → 0 while it moves stuff around between the ssd swap space and ram. It’s definitely not playable, but if it had more ram it definitely would be.

I installed it on my Steam Deck a while back as well. Was an interesting experiment for sure. But like you said, there is simply not enough ram to run it. In fact, it wouldn’t even launch until I set a 16GB swap file if I recall.

1 Like

I had this same issue where the mouse would slam to my feet when using the interact mouse, it was a problem with Wayland, swapping to X11 solved it for me. I tried a bunch of wine settings and none seemed to work, so I caved and just launched X11 when I wanted to play sc.

This was on my desktop in NixOS so I’m not sure how it behaves on your setup

1 Like

I am here using it with Vulkan 8 and wayland only.
Works flawless. Smoother then my i7 7800K, 32Gb Ram, GTX 1080Ti setup.
Bet the CPU and the 64Gb ram help here. Also the faster NVME SSD’s.
Amazingly, when I’m walking around, the GPU temp does not go that up, so the fans are barely audible. As you can see in the pic , the overall system temp remains quite low.

Well, now I’m real excited to get my framework. Even more so than before. I think it’s going to be a great replacement for both my current laptop and my desktop. Hopefully batch 17 will ship soon. I know batch 8 just got notifications from the tracker posts, but still, I hope they get it pushed out quickly :smiley:

One note - I noticed when in Wayland mode, fractional scaling causes the mouse to be shifted down/left. Means if I put the screen scaling to 125% (because of my extra screen), the mouse click is not where the mouse pointer is in games. All that is at the bottom of the screen can’t be reached.
So - disable scaling and put it to 100% - and it works!

Also tried Cyberpunk yesterday… Fan go up rather strong. Star citizen is way better in terms of resource usage and efficiency I think :slight_smile:

Anyone got the problem upon starting starfield through steam?

File: …/src-wine/dlls/winevulkan/loader_thunks.c
Line: 2604
Expression: “!status && vkCreateComputePipelines”"
Press OK to exit the program, or Cancel to start the Wine debugger

I have dGPU, 16GB RAM and running on proton experimental

The earthquake in Taiwan is likely to set that back a few weeks.