[TRACKING] Fedora Freezes and Flickering on newer Kernels

I should mention that my Linux skill-level is low. I’ve only toyed with Linux here and there, but six months ago, switched to Linux on Framework as my daily driver.

I did take a look at that post, but I don’t see anything on my machine at this location:

So, I thought maybe that was just for Mint.

Take care,

Really? That is weird, because Fedora also seems to support grub.

If that file really does not exist, you likey use systemd-boot.

He seems to be using PopOS so adding kernel parameters would be something like this here

So using
sudo kernelstub -a “i915.enable_psr=0”
should do it.

1 Like

Sorry it’s too early in the morning, I saw the thread title and didn’t read his OS…
Thanks for catching that!

You’re right, PopOS does use kernelstub.

Thanks @mcz and @Anachron for your insight, but it still does it.

I ran
sudo kernelstub -a “i915.enable_psr=0”
in the terminal, it didn’t give me any feedback, so I can’t confirm that it took…

Restarted; still does it. Switched back to X11; still does it.

I tried kernelstub -v to see if I can see if the property is set, but it doesn’t show it in the output.

Take care,

After staring at the output for a bit, I do see it there (did I mention that I’m a little bit low-vision)… sorry.

It says this:
Kernel Boot Options:.quiet loglevel=0 systemd.show_status=false splash “i915.enable_psr=0”

Is it supposed to be in quotes like that? None other key/values are.


I dont think so, please remove them.

@Anachron and @mcz ,
Well. I don’t want to speak too soon, but so far: so good.

Setting the kernel boot option without the quotes seems to have taken care of the issue.
sudo kernelstub -a i915.enable_psr=0

I’ll continue with my daily driving, do more testing and keep an eye on it.

If it wasn’t for good folks like you in this community, I might’a gave up.

Thank you,

1 Like

Glad to be of service!

If it happens again, feel free to update this thread and give me a ping.

Enjoy your framework!


Happy to have stumbled across this thread by chance—I’ve been noticing some weird freezing and flickering/jittering of late, and I’ve so far had no real luck isolating a specific trigger. I’m not sure if what I’m seeing matches the typical experience here, as I haven’t seen any hard freezes, and I don’t use a DE with Fedora. The problem typically manifests as the following:

  1. cursor freezes in place for 2-4 seconds
  2. screen flickers/jitters briefly (looks like a flash of black with some tearing) before control is restored
  3. repeat after 10 or so seconds

Suspending the machine and waking it after a few seconds has resolved the issue in a couple of cases, but there have been other occasions on which a full reboot was necessary.

I don’t have GNOME installed at all (just the Sway window manager), so none of the possible triggers related to GNOME-only features like Night Light apply. I also don’t have any docks or other peripherals connected to my Framework.

I do see a couple—but just a couple!—of these lines in old /var/log/messages logs:

kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:0:00000000

It doesn’t appear that there’s a corresponding line of this type for every time this problem has occurred, but it does seem like the i915 chip is fairly notorious for causing problems… the options i915 enable_psr=0 fix seems like it might be the best we get for now (although I know Sway 1.8 has a new wlroots that may help in my case).

Will try adding the fix and seeing if it helps until we have a more permanent fix, but in the meantime, here are my answers to the above questions:

Fedora 36 or 37: 37
12th gen or 11th gen: 12th
Kernel version: Linux 6.0.18-300.fc37.x86_64 x86_64
Gnome version: None (Sway 1.7)
Using i915 fixes, if so, which ones: Not yet
Has this been tried yet and if so, any difference: Not yet
Applications running in foreground or background when freeze occurs: Firefox, Thunderbird, Discord, foot
What if anything is attached to your Framework; docks, (BT, IR, wired) mouse, keyboard: Nothing

I decided to try out Silverblue two weeks ago, this may or may not help us narrow down whatever is causing these issues.

  • Fedora 36 or 37: 37 Silverblue
  • 12th gen or 11th gen: 1240P
  • Kernel version: 6.1.6-200.fc37.x86_64
  • Gnome version: 43.2
  • Using i915 fixes, if so, which ones: not tried yet
  • Has this been tried yet and if so, any difference: not tried yet
  • Applications running in foreground or background when freeze occurs: generally the Firefox rpm
  • What if anything is attached to your Framework; docks, (BT, IR, wired) mouse, keyboard: second monitor via hdmi, keyboard and mouse over usb, ethernet over usb: freezes occur whether or not anything is attached, nor does battery mode / cable seem to affect them.

Additonal notes

  • the freezing occurs a few times per day for a few seconds
  • the flickering of the upper few pixel rows gets markedly worse whenever nightmode is activated and tuning down the blue light during sundown, with nightmode turned off it happens occasionally during the day
  • all layered packages: btop, gnome-tweaks, intel-media-driver, langpacks-de, openssl, powertop, steam-devices, tlp
  • all tweaks:
sudo grubby --update-kernel=ALL --args="module_blacklist=hid_sensor_hub"
sudo grubby --update-kernel=ALL --remove-args="quiet"
sudo grubby --update-kernel=ALL --remove-args="rhgb"
sudo grubby --update-kernel=ALL --args="nvme.noacpi=1"
sudo rpm-ostree kargs --append='mem_sleep_default=deep'

All data same as my earlier post. 1st soft freeze since December 26th. No hard freezes in this time frame.

kernel: Asynchronous wait on fence 0000:00:02.0:gnome-shell[2562]:3dadc timed out (hint:intel_atomic_commit_ready [i915])
kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 12:0:00000000
kernel: i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
kernel: i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_70.bin version 70.5.1
kernel: i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc.bin version 7.9.3
kernel: i915 0000:00:02.0: [drm] HuC authenticated
kernel: i915 0000:00:02.0: [drm] GuC submission enabled
kernel: i915 0000:00:02.0: [drm] GuC SLPC enabledJan 21 13:07:32 Nuada 
firefox.desktop[3771]: Crash Annotation GraphicsCriticalError: |[0][GFX1-]: GFX: RenderThread detected a device reset in PostUpdate (t=10761.2)

More convinced than ever that a whole lot of this is on the gnome-shell and mutter.

1 Like

FYI: New Intel Media Driver dropped on Fedora 37 today. This one should have a bunch of fixes. SO if you are an infrequent updater, today might be a good day to do so :slight_smile:

1 Like

This is very helpful as the video visually demonstrates what is happening. I’m collecting data, so this is helpful.

Because you’re on Pop OS and may have a unique opportunity here, have you rebooted into “oldkern” to see if this behavior continued there?

Has doing a:

sudo kernelstub -o "quiet splash i915.enable_psr=0"

and reboot change anything for you?

Okay folks, this is where we see what happens! Please update and let me know after installing updates/rebooting, how it goes?

Thanks @Matt_Hartley for the heads up on the Media Driver in today’s update. I’ll update as soon as I finish this message. I usually updates daily.

I have been experiencing the freezing since receiving my 12th gen board. Here are the details to add to your spreadsheet:

Fedora 36 or 37: 37, and updating almost daily

12th gen or 11th gen: 12th gen

Kernel version: 6.1.7-200

Gnome version: 43.2-1 (at least for gnome-shell

Using i915 fixes, if so, which ones: None

Applications running in foreground or background when freeze occurs: I only experience it when I have an external monitor or external projector connected. I also get it when sharing a screen with zoom, but in every instance that I remember I also had an external monitor connected, so can’t confirm that zoom is contributing to the issue. I know I still get it without zoom, most notably when I have the screen in mirror mode and presenting in front of a class. I’ve only ever seen in on the laptop screen, and the mirrored projector does not show the 2-3 second freeze, nor does the Zoom screenshare show the freeze. I have also had a few hard freezes where a forced shutdown was required, which I’m not sure is related to this issue or not, but have no reason to suspect anything else

What if anything is attached to your Framework; docks, (BT, IR, wired) mouse, keyboard: I have had this occur with nothing but power connected on one USB port and a Framework HDMI or DVI port connected monitor. I have experienced it through both HDMI and DVI ports independently. I have also used presenter devices such as Logitech Spotlight, but also experience it without it.

@Matt_Hartley When you said multimedia updates, were you talking about the pipewire updates? If so, I updated them 24 hours ago, and was still experiencing the flickers today. I don’t see anything related to multimedia available at this moment.

Here is what I updated yesterday and the day before, none of which fixed the flicker issues:

Transaction ID : 171
Begin time     : Tue 24 Jan 2023 01:54:09 AM MST
Begin rpmdb    : 9d7a69bd65d6e7bb18c889f176151dfc1a25d99cc8ba6c03c3d64674e90eaa16
End time       : Tue 24 Jan 2023 01:55:25 AM MST (76 seconds)
End rpmdb      : fff81fe7faee4b039ea22c9e408d12ca92eb5db63516de12b09401ed4b675249
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Install  kernel-6.1.7-200.fc37.x86_64                                  @updates
    Install  kernel-core-6.1.7-200.fc37.x86_64                             @updates
    Install  kernel-devel-6.1.7-200.fc37.x86_64                            @updates
    Install  kernel-modules-6.1.7-200.fc37.x86_64                          @updates
    Install  kernel-modules-extra-6.1.7-200.fc37.x86_64                    @updates
    Upgrade  fd-find-8.2.1-10.fc37.x86_64                                  @updates
    Upgrade  kernel-devel-matched-6.1.7-200.fc37.x86_64                    @updates
    Upgrade  libnfsidmap-1:2.6.2-2.rc6.fc37.x86_64                         @updates
    Upgrade  nfs-utils-1:2.6.2-2.rc6.fc37.x86_64                           @updates
    Upgrade  pipewire-0.3.64-2.fc37.x86_64                                 @updates
    Upgrade  pipewire-alsa-0.3.64-2.fc37.x86_64                            @updates
    Upgrade  pipewire-gstreamer-0.3.64-2.fc37.x86_64                       @updates
    Upgrade  pipewire-jack-audio-connection-kit-0.3.64-2.fc37.x86_64       @updates
    Upgrade  pipewire-libs-0.3.64-2.fc37.x86_64                            @updates
    Upgrade  pipewire-pulseaudio-0.3.64-2.fc37.x86_64                      @updates
    Upgrade  pipewire-utils-0.3.64-2.fc37.x86_64                           @updates
    Upgraded kernel-6.0.18-300.fc37.x86_64                                 @@System
    Upgraded kernel-core-6.0.18-300.fc37.x86_64                            @@System
    Upgraded kernel-devel-6.0.18-300.fc37.x86_64                           @@System
    Upgraded kernel-modules-6.0.18-300.fc37.x86_64                         @@System
    Upgraded kernel-modules-extra-6.0.18-300.fc37.x86_64                   @@System
    Removed  kmod-v4l2loopback-6.0.18-300.fc37.x86_64-0.12.7-2.fc37.x86_64 @@System
    Upgraded fd-find-8.2.1-8.fc37.x86_64                                   @@System
    Upgraded kernel-devel-matched-6.1.6-200.fc37.x86_64                    @@System
    Upgraded libnfsidmap-1:2.6.2-2.rc5.fc37.x86_64                         @@System
    Upgraded nfs-utils-1:2.6.2-2.rc5.fc37.x86_64                           @@System
    Upgraded pipewire-0.3.64-1.fc37.x86_64                                 @@System
    Upgraded pipewire-alsa-0.3.64-1.fc37.x86_64                            @@System
    Upgraded pipewire-gstreamer-0.3.64-1.fc37.x86_64                       @@System
    Upgraded pipewire-jack-audio-connection-kit-0.3.64-1.fc37.x86_64       @@System
    Upgraded pipewire-libs-0.3.64-1.fc37.x86_64                            @@System
    Upgraded pipewire-pulseaudio-0.3.64-1.fc37.x86_64                      @@System
    Upgraded pipewire-utils-0.3.64-1.fc37.x86_64                           @@System
Transaction ID : 170
Begin time     : Mon 23 Jan 2023 02:00:20 AM MST
Begin rpmdb    : b55e179abce3bf3cb8c46ed79adddc6e7ac6a3917281542a522e9e1c9bcc6807
End time       : Mon 23 Jan 2023 02:00:42 AM MST (22 seconds)
End rpmdb      : 9d7a69bd65d6e7bb18c889f176151dfc1a25d99cc8ba6c03c3d64674e90eaa16
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Install  libplacebo-4.208.0-1.fc37.x86_64                                  @fedora
    Upgrade  ModemManager-1.18.12-1.fc37.x86_64                                @updates
    Upgrade  ModemManager-glib-1.18.12-1.fc37.x86_64                           @updates
    Upgrade  NetworkManager-1:1.40.10-1.fc37.x86_64                            @updates
    Upgrade  NetworkManager-adsl-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  NetworkManager-bluetooth-1:1.40.10-1.fc37.x86_64                  @updates
    Upgrade  NetworkManager-config-connectivity-fedora-1:1.40.10-1.fc37.noarch @updates
    Upgrade  NetworkManager-libnm-1:1.40.10-1.fc37.x86_64                      @updates
    Upgrade  NetworkManager-ppp-1:1.40.10-1.fc37.x86_64                        @updates
    Upgrade  NetworkManager-team-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  NetworkManager-wifi-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  NetworkManager-wwan-1:1.40.10-1.fc37.x86_64                       @updates
    Upgrade  efivar-libs-38-6.fc37.x86_64                                      @updates
    Upgrade  firefox-109.0-1.fc37.x86_64                                       @updates
    Upgrade  firefox-langpacks-109.0-1.fc37.x86_64                             @updates
    Upgrade  git-2.39.1-1.fc37.x86_64                                          @updates
    Upgrade  git-core-2.39.1-1.fc37.x86_64                                     @updates
    Upgrade  git-core-doc-2.39.1-1.fc37.noarch                                 @updates
    Upgrade  gjs-1.74.1-5.fc37.x86_64                                          @updates
    Upgrade  ibus-1.5.27-5.fc37.x86_64                                         @updates
    Upgrade  ibus-gtk3-1.5.27-5.fc37.x86_64                                    @updates
    Upgrade  ibus-libs-1.5.27-5.fc37.x86_64                                    @updates
    Upgrade  ibus-setup-1.5.27-5.fc37.noarch                                   @updates
    Upgrade  iptables-libs-1.8.8-4.fc37.x86_64                                 @updates
    Upgrade  iptables-nft-1.8.8-4.fc37.x86_64                                  @updates
    Upgrade  koji-1.31.1-1.fc37.noarch                                         @updates
    Upgrade  libXpm-3.5.15-2.fc37.x86_64                                       @updates
    Upgrade  libinput-1.22.1-1.fc37.x86_64                                     @updates
    Upgrade  libnumbertext-1.0.11-1.fc37.x86_64                                @updates
    Upgrade  libqmi-1.30.8-1.fc37.x86_64                                       @updates
    Upgrade  libqmi-utils-1.30.8-1.fc37.x86_64                                 @updates
    Upgrade  libsoup3-3.2.2-2.fc37.x86_64                                      @updates
    Upgrade  libwebp-1.3.0-1.fc37.x86_64                                       @updates
    Upgrade  llvm-libs-15.0.7-1.fc37.x86_64                                    @updates
    Upgrade  mozjs102-102.7.0-1.fc37.x86_64                                    @updates
    Upgrade  mpg123-libs-1.31.2-1.fc37.x86_64                                  @updates
    Upgrade  perl-Git-2.39.1-1.fc37.noarch                                     @updates
    Upgrade  python-unversioned-command-3.11.1-3.fc37.noarch                   @updates
    Upgrade  python3-3.11.1-3.fc37.x86_64                                      @updates
    Upgrade  python3-devel-3.11.1-3.fc37.x86_64                                @updates
    Upgrade  python3-koji-1.31.1-1.fc37.noarch                                 @updates
    Upgrade  python3-libs-3.11.1-3.fc37.x86_64                                 @updates
    Upgrade  python3-pytz-2022.7.1-1.fc37.noarch                               @updates
    Upgrade  python3-tkinter-3.11.1-3.fc37.x86_64                              @updates
    Upgrade  python3-unbound-1.17.1-1.fc37.x86_64                              @updates
    Upgrade  rav1e-libs-0.5.1-6.fc37.x86_64                                    @updates
    Upgrade  selinux-policy-37.18-1.fc37.noarch                                @updates
    Upgrade  selinux-policy-targeted-37.18-1.fc37.noarch                       @updates
    Upgrade  sudo-1.9.12-1.p2.fc37.x86_64                                      @updates
    Upgrade  sudo-python-plugin-1.9.12-1.p2.fc37.x86_64                        @updates
    Upgrade  unbound-anchor-1.17.1-1.fc37.x86_64                               @updates
    Upgrade  unbound-libs-1.17.1-1.fc37.x86_64                                 @updates
    Upgrade  usbutils-015-1.fc37.x86_64                                        @updates
    Upgrade  vim-common-2:9.0.1221-1.fc37.x86_64                               @updates
    Upgrade  vim-data-2:9.0.1221-1.fc37.noarch                                 @updates
    Upgrade  vim-enhanced-2:9.0.1221-1.fc37.x86_64                             @updates
    Upgrade  vim-filesystem-2:9.0.1221-1.fc37.noarch                           @updates
    Upgrade  vim-minimal-2:9.0.1221-1.fc37.x86_64                              @updates
    Upgrade  ffmpeg-5.1.2-9.fc37.x86_64                                        @rpmfusion-free-updates
    Upgrade  ffmpeg-libs-5.1.2-9.fc37.x86_64                                   @rpmfusion-free-updates
    Upgrade  gstreamer1-plugins-bad-freeworld-1:1.20.5-1.fc37.x86_64           @rpmfusion-free-updates
    Upgrade  gstreamer1-plugins-ugly-1:1.20.5-1.fc37.x86_64                    @rpmfusion-free-updates
    Upgrade  libavdevice-5.1.2-9.fc37.x86_64                                   @rpmfusion-free-updates
    Upgraded ModemManager-1.18.8-2.fc37.x86_64                                 @@System
    Upgraded ModemManager-glib-1.18.8-2.fc37.x86_64                            @@System
    Upgraded NetworkManager-1:1.40.6-1.fc37.x86_64                             @@System
    Upgraded NetworkManager-adsl-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded NetworkManager-bluetooth-1:1.40.6-1.fc37.x86_64                   @@System
    Upgraded NetworkManager-config-connectivity-fedora-1:1.40.6-1.fc37.noarch  @@System
    Upgraded NetworkManager-libnm-1:1.40.6-1.fc37.x86_64                       @@System
    Upgraded NetworkManager-ppp-1:1.40.6-1.fc37.x86_64                         @@System
    Upgraded NetworkManager-team-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded NetworkManager-wifi-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded NetworkManager-wwan-1:1.40.6-1.fc37.x86_64                        @@System
    Upgraded efivar-libs-38-5.fc37.x86_64                                      @@System
    Upgraded firefox-108.0.1-3.fc37.x86_64                                     @@System
    Upgraded firefox-langpacks-108.0.1-3.fc37.x86_64                           @@System
    Upgraded git-2.39.0-1.fc37.x86_64                                          @@System
    Upgraded git-core-2.39.0-1.fc37.x86_64                                     @@System
    Upgraded git-core-doc-2.39.0-1.fc37.noarch                                 @@System
    Upgraded gjs-1.74.1-3.fc37.x86_64                                          @@System
    Upgraded ibus-1.5.27-4.fc37.x86_64                                         @@System
    Upgraded ibus-gtk3-1.5.27-4.fc37.x86_64                                    @@System
    Upgraded ibus-libs-1.5.27-4.fc37.x86_64                                    @@System
    Upgraded ibus-setup-1.5.27-4.fc37.noarch                                   @@System
    Upgraded iptables-libs-1.8.8-3.fc37.x86_64                                 @@System
    Upgraded iptables-nft-1.8.8-3.fc37.x86_64                                  @@System
    Upgraded koji-1.31.0-1.fc37.noarch                                         @@System
    Upgraded libXpm-3.5.13-8.fc37.x86_64                                       @@System
    Upgraded libinput-1.22.0-2.fc37.x86_64                                     @@System
    Upgraded libnumbertext-1.0.10-2.fc37.x86_64                                @@System
    Upgraded libqmi-1.30.6-2.fc37.x86_64                                       @@System
    Upgraded libqmi-utils-1.30.6-2.fc37.x86_64                                 @@System
    Upgraded libsoup3-3.2.2-1.fc37.x86_64                                      @@System
    Upgraded libwebp-1.2.4-2.fc37.x86_64                                       @@System
    Upgraded llvm-libs-15.0.6-1.fc37.x86_64                                    @@System
    Upgraded mozjs102-102.6.0-1.fc37.x86_64                                    @@System
    Upgraded mpg123-libs-1.31.1-1.fc37.x86_64                                  @@System
    Upgraded perl-Git-2.39.0-1.fc37.noarch                                     @@System
    Upgraded python-unversioned-command-3.11.1-1.fc37.noarch                   @@System
    Upgraded python3-3.11.1-1.fc37.x86_64                                      @@System
    Upgraded python3-devel-3.11.1-1.fc37.x86_64                                @@System
    Upgraded python3-koji-1.31.0-1.fc37.noarch                                 @@System
    Upgraded python3-libs-3.11.1-1.fc37.x86_64                                 @@System
    Upgraded python3-pytz-2022.7-1.fc37.noarch                                 @@System
    Upgraded python3-tkinter-3.11.1-1.fc37.x86_64                              @@System
    Upgraded python3-unbound-1.17.0-1.fc37.x86_64                              @@System
    Upgraded rav1e-libs-0.5.1-5.fc37.x86_64                                    @@System
    Upgraded selinux-policy-37.17-1.fc37.noarch                                @@System
    Upgraded selinux-policy-targeted-37.17-1.fc37.noarch                       @@System
    Upgraded sudo-1.9.11-4.p3.fc37.x86_64                                      @@System
    Upgraded sudo-python-plugin-1.9.11-4.p3.fc37.x86_64                        @@System
    Upgraded unbound-anchor-1.17.0-1.fc37.x86_64                               @@System
    Upgraded unbound-libs-1.17.0-1.fc37.x86_64                                 @@System
    Upgraded usbutils-014-3.fc37.x86_64                                        @@System
    Upgraded vim-common-2:9.0.1182-1.fc37.x86_64                               @@System
    Upgraded vim-data-2:9.0.1182-1.fc37.noarch                                 @@System
    Upgraded vim-enhanced-2:9.0.1182-1.fc37.x86_64                             @@System
    Upgraded vim-filesystem-2:9.0.1182-1.fc37.noarch                           @@System
    Upgraded vim-minimal-2:9.0.1182-1.fc37.x86_64                              @@System
    Upgraded ffmpeg-5.1.2-3.fc37.x86_64                                        @@System
    Upgraded ffmpeg-libs-5.1.2-3.fc37.x86_64                                   @@System
    Upgraded gstreamer1-plugins-bad-freeworld-1:1.20.4-1.fc37.x86_64           @@System
    Upgraded gstreamer1-plugins-ugly-1:1.20.4-1.fc37.x86_64                    @@System
    Upgraded libavdevice-5.1.2-3.fc37.x86_64                                   @@System

Updated yesterday (F37). Package to look out for should be the Intel(R) Media Driver for VAAPI in version

1 Like

@Simon_F @Matt_Hartley

Well, that is another bullet to add to Matt’s table. I didn’t have intel-media-driver installed on my machine. I had intel-mediasdk, but I’m not sure there was any value of having that without the driver, or how I missed the driver… I’m guessing that means there is a low likelihood that intel-media-driver played any affect in the flickering.

On a side note, I just taught another 8 hour session with an external monitor connected and sharing a screen with zoom, same as I did yesterday, but today I didn’t have any flicking issues. The only change I had made between sessions was doing the bios update. Since class ended an hours ago, I’ve added intel-media-driver and oneVPL so I’ll test for any flickering issues during tomorrow’s 8 hour class session. And for reference, I have never gone through an 8 hour class session since getting the 12th gen motherboard 6 months ago and not had flickering atleast 50% of the class session. I have also found that using the CTRL key to locate mouse pointer (used to emphasis bullets in slides while teaching) is a great way to case the flicker to occur on demand during that 50% of the time.

The new intel-gpu-firmware just dropped.

1 Like