[TRACKING] WIFI Network adapter disappearing (when physically moving laptop?)

I’m running Ubuntu 22.04 on my 12th gen with an AX210 wireless card.

Starting a few weeks ago, my network adapter would occasionally stop working and disappear. The only way to get it working again was by restarting my laptop. This seemed to occur when I physically moved my laptop away from my desk, but it wasn’t consistent so I wasn’t sure. I initially thought it was because my network adapter was getting confused when going from one wi-fi connection to another, but I tested it in a location with only 1 wi-fi network and had the same issue.

This past week, it’s gotten worse and everytime I move my laptop off my a flat surface, the network adapter goes out. When I restart my computer, about half the time it will also not be detected. I chased some software solutions, including turning off fast boot in BIOS, but did not have any consistent success.

At this point, I suspect it’s a hardware issue, but I want to check to rule out software problems if this is a known problem for anyone else. If it is a hardware issue, would appreciate any help in troubleshooting, as playing Russian roulette everytime I move my laptop has been incredibly stressful.

I’ve experienced similar behaviour.

At first reboots would temporarily resolve the issue, but over time it got worse and my system would freeze during boot due to iwlwifi getting very upset with my WiFi card, and I would have to reseat the card on a semi-regular basis just to boot.

I’ve documented my troubleshooting steps here, which may help you resolve the problem or share with us the extent of it:

1 Like

Thanks @groundwork, this sounds like the identical issue I have. Did you end up resolving the issue without getting a new wifi card?

I’ll try reseating the wifi card and report back.

Hi @kxp I would echo the re-seating of the card and making sure everything is snug. Definitely odd, does it disappear from lspci when it vanishes?

Yes, it disappears from lspci. I can reproduce the problem pretty easily, so when I run dmesg -w I can see the network adapter disconnect when I lift my laptop. I’m traveling, so trying to get a hold of a T5 screwdriver to tighten things up and hopefully resolve the problem…

This may be hardware indeed, but we’ll want to test out a few things first before writing off the card. Please open a support ticket here and link to this thread.

Unfortunately not. The Framework support team ran me through a few troubleshooting steps and have now escalated my issue for replacement processing.

1 Like

Appreciate the update on this. Thanks

I haven’t had any issues since re-seating my wireless card by following this guide

2 Likes

Appreciate the update, marking this as solved.

Looks like I jinxed myself - the same problem re-emerged yesterday after 2 weeks of working fine, will follow up with my support ticket

1 Like

Oh no! Yes, that is the best bet at this point. Darn, thought we had this handled.

Any updates on this? I’m having very similar issues on Ubuntu 22.04 on my Framework 13" (Intel 12th gen). Wifi adapter randomly drops out.

No, as the op’s issue was resolved. This is with the AX210? Which distro release and kernel?

yes AX210. Ubuntu 22.04 Kernel: Linux 6.1.0-1027-oem x86_64

When it disappears, please check the following - to determine if this may be hardware of the OS is the issue.

rfkill

(Is anything showing soft blocked)

lspci | grep AX210

(On my other FW laptop at the moment, so I am assuming grep should find AX210), otherwise run lspci and search manually)

When it disappears, rfkill shows it missing entirely and so does lspci, I’d say this is ticket worthy as the card may be bad. If it comes to creating a ticket, save yourself some time and make sure to link to this thread.

Wifi gave up recently. Here’s what I was able to capture:

stu@fw:~$ rfkill
ID TYPE      DEVICE      SOFT      HARD
 1 wlan      phy0   unblocked unblocked
 2 bluetooth hci0   unblocked unblocked
stu@fw:~$ lspci | grep AX210
a6:00.0 Network controller: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)

Any ideas on where I should go with this? Still experiencing random wifi drops followed by the fans spinning up. Is a new network card worth trying?

Hi @Stuart_Bowman,

I’ll need to see logs as I cannot think of any reason why OEM C or D would have issues with your card. I’ll need to see a course of events from the full logs as there may be something else at play here.

All affected, as always, please test against a Live USB of Ubuntu 22.04.3 as it will have older updates and a different kernel. If it doesn’t error in that environment, we then may have spotted a bug that is worth tracking down with full logs in a ticket.