Unable to ship to District of Columbia addresses

I’m a huge fan of the Framework laptop and have purchased a few already for work, but yesterday I tried to order a new Framework laptop for a colleague that lives in Washington, DC, but the “District of Columbia” doesn’t appear in the “State” dropdown. Many of my colleagues live in DC, so would love to be able to ship there.

I opened a support ticket, but haven’t had a response (I’m sure they’re slammed with the expansion efforts), so just wondering if anyone here has any workarounds.


I just looked and it’s there in the list (at least for delivery address) when I try. The list can be filtered using a search term, perhaps try searching for Columbia rather than scrolling through - it could be that the list is not entirely alphabetical for some reason.

@andyk2 - thanks for the heads up! It’s there now. I definitely tried searching and went through the whole list before, but it’s there now. Just put in my order. Thank you for your help!

1 Like