USB-C DisplayLink Dock Prevents Shutdown and Post

Hello all,

I am having a weird issue. I have a USB-C DisplayLink dock which has worked perfectly on several HP Envy laptops. When I attempted to get it working on the framework, however, I am having some major issues with getting the laptop to shut down, or boot, when the dock is connected.

The dock in question is a Visiontek VT4500. This uses Synaptics DisplayLink drivers to operate. I had first thought this was an issue with linux and the grub bootloader, however I have completely removed my linux installation and am currently running on windows only and am still having issues.

Shut Down Issue Replication:

  1. Boot windows
  2. Plug the power supply into the dock and nothing else
  3. Plug the dock into the laptop
  4. Attempt to shut down windows

Result: Windows will shut down as normal, but once windows has appeared to shut down, the screen will go black, but the backlight will stay on, the power button will stay lit, and after a little while the fans will ramp up to their highest speed. The only way to get out of this is to hold down the power button for a solid 10 seconds.

Post Prevention Replication:

  1. Plug power supply into the dock and nothing else
  2. plug the dock into the laptop
  3. Power on the laptop

Result: The laptop will not post. You will never see the framework logo, you can not get the bios to load, tapping F2 or F12 does nothing. You can tell that it has not posted because the instant you press the power button the whole laptop shuts off instantly. There is no need to press and hold the power button. Again, in this state the display is black but the backlight is clearly on.

I have not attempted moving the USB-C expansion slot around and verifying that it does this for every expansion slot. I also have not attempted this with their USB-C to USB-A 3.0 cable which does not include power delivery. I plan on continuing to test and experiment to provide more detailed data on exact requirements to replicate these issues.

1 Like

I haven’t gotten the same posting issue but I have the same issue with shutting down. It happens when I have my laptop plugged into a USB-C hub/dock. It’s not a DisplayLink dock however.

2 Likes

UPDATE:

I just completed a bunch of further testing to see exactly what was required to reproduce both of the above bugs. I was able to get very good data on the bug preventing the laptop from posting, but the shutdown issue seemed to be harder to reproduce. I’m still working on that one and will need some more time to figure out the details on this setup, because I was able to get scenarios where it would shut down just fine with the dock plugged in.

Dock Preventing Post details:

After further testing I was able to determine that the expansion slot that the dock was plugged into does not matter. The dock also provided a USB-C to USB-A 3.0 cable that is meant to be an alternative means to connecting the dock to the PC. When this cable was connected instead of USB-C to USB-C the computer still wouldn’t post.

I was not able to find any configuration where the dock was plugged into the laptop and the laptop would successfully post.

Dock Preventing Shutdown Details:

After further testing I was able to get windows to shut down with nothing plugged into the dock using either the USB-A to C cable, or the C to C cable to connect the dock to the computer, but in one instance it still failed to shutdown with nothing but the computer connected to the dock. Because its being intermittent, I need to do further testing to see what combination of connected peripherals appear to causing this bug to appear more often.

1 Like

Can you connect the dock directly to the USB-C on the main board (instead of through the USB-C card)?

1 Like

Quick update, here is a video of the power lights flashing as it attempts to post with the dock attached: 20211027_153940.mp4 - Google Drive

I will give this a try and get back to you on that.

3 Likes

Did you ever come up with a workaround for this issue?
My wife’s laptop hangs on shutdown. (Basically it stays powered on even after the OS has shut down.)
I have to physically unplug the USB-C dock, then it shuts down correctly.
Then I have to power it on again and sometimes I have to unplug and replug the dock for the display to be activated (even though USB passthrough works just fine)
So frustrating.

1 Like

Is it a thunderbolt or a USB dock?
And, again, can you try without the “adapter card”?
Framework’s expansion cards seem to contain active “translation chips” or handshake ICs for some reason. I don’t like that.

1 Like

I’m having a possibly related issue with this USB-C dock:

https://www.amazon.com/gp/product/B0746P6LPP/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Works fine for my other laptops, but my Framework laptop (BIOS 3.07, purchased in February this year) will not post while it’s connected.

The Framework does as others have described above (except on power-on, not shutdown); system powers on, backlight turns on, screen stays black then the cooling fan ramps up to full blast. I let it go for a bit because I thought maybe it was doing a memory test for some reason but 10 minutes on and nothing changed. Holding the power button down for 10s rebooted the system and the same thing happens again. If I unplug the dock and reboot it boots normally, then I can plug the dock back in and everything works as expected.

it really don’t like thunderbolt accessories.
Is there like a thunderbolt security setting? or a thunderbolt pre-boot module enable/disable?

Also, this seems (especially with the pricing) like a USB-C dock (not TB) that wants a “DisplayPort Alt Mode USB Power Delivery USB 3.2” port, not a thunderbolt.

A thunderbolt dock should cost at least $125 (bridge chip and associated circuitry)
https://www.amazon.com/Belkin-Thunderbolt-Windows-Laptops-Transfer/dp/B07R5CB6HY/
Like this belkin dock.

And even if it says “intel certified” I still highly doubt that this is actually TB because of the price
https://www.amazon.com/Certified-Cable-Matters-Thunderbolt-Compatible/dp/B08DYDV5DD/

You should be able to tell if it is a actual thunderbolt or not if you go to device manager and find the dock. It might help by list things by “devices by connections”

Update:

It seems it’s not the USB-C hub at all causing the problem, it may be my ASUS ROG Gladius gaming mouse…

Today I had a problem booting when I had the mouse plugged in directly so I tried:

A) mouse only on laptop USB-A (no boot)
B) USB-C hub with monitor, keyboard, mouse (no boot)
C) gaming keyboard only on laptop USB-A (boots)
D) USB-C hub with monitor, keyboard, no mouse (boots)

Strange because I’ve had no problems with this mouse being connected during boot on 4 other systems. Likely not related to USB-C at all and this thread no longer applies.

Oh yes. I have read about it because some mouse have internal storage (or some other stuff) that make the system think it’s a bootable drive of some sort
Which it isn’t, so it just hangs there.