Very low wifi speed of 2 MBPS

On my brand new Gen 11 I’m experiencing very low wifi speed of 2 MBPS over 2.4g despite showing 3/4 bars. My cellphone is pushing 50mbps from the same position. When the laptop is only inches from router, it reaches the same speed as the cellphone.

I am running Windows 11 Pro, with the latest framework drivers and bios. My router is an e4200 with only 2.4g enabled.

I found the installation of the wifi card to be very difficult. The wires are physically too long and there was no way to arrange them as shown in the instructional photos. They are however snapped in tightly into the tiny sockets and secured with the metal bracket.

Please help me figure out what is wrong. I had high hopes for this otherwise amazing modular laptop!

Try the posted link to Intel DSA. There have been a number of Intel Driver updates.

SOLVED Win11, 1165, 3.07 Bios/Drivers No WiFi

Something strange happened this morning. My speed went up to 20mbps. This is before installing the Intel helper DSA. At the same time, my ancient Pixel 2 clocked in at 50mbps.

After installing the Intel DSA and updated my drivers, my speed remained at 20mpbs. My old phone’s wifi consistently outperforms framework by over 50%.

What else could be causing this drop in speed?

And thank you for the Intel link. I had a graphics and bluetooth driver that needed updating and it took care of that!

The bracket was always installed.

I took a photo with the bracket off to show wire alignment.

OK, sorry.

Make sure the connectors are well seated.

They are snapped in tightly. What else can I do to diagnose this issue?

How wires are arranged near the right hinge? Have you touched/rerouted them? There’s a tight spot where wires can be easily damaged. See the antenna replacement manual to check that yours are arranged properly.


This is a good idea to check, I’ve noticed the extra protection layers of my antenna cables in this area are damaged from a part of the power button retention frame.

1 Like

So I guess some QC steps were not defined at the factory…and it’s just cheaper for customer to call support if it’s damaged. As opposed to implementing the QC step to ensure antenna cable is not damaged from the factory? (e.g. low likelihood of damaged antenna. A balance between costs for QC, or cost for support) Or is this a case of QC escape?

Check and see if you’re connecting on a 2.4Ghz (20mhz or 40mhz band). If you haven’t yet change the settings on your router to be Wireless N connections only. Might be a fallback to wireless b/g speeds in the laptop - which might not be supported by the phone.

Also check for firmware updates to the router. Consider using OpenWRT if you’re more technically inclined for firmware and your version of the Linksys E4200 supports it.

Here is a photo of my wiring:

Does it look like there is damage?

I installed the latest firmware and had no improvement.

My settings are:

  • Wireless N-only
  • 20mhz only
  • Channel auto

In my living room the speed is 15mbps, in my bedroom 35mbps and inches from the router 57 mbps. The closer I am to the router the higher the speed, but when head to head with my old cellphone, the framework is always at least 50% slower.

I don’t want to derail the topic so briefly, the extra layer of insulation for that area is getting damaged but the cables themselves are currently not and I have never had WiFi problems.

I don’t think it has anything to do with QC but rather from this square edge on the PWR button retention clip (designed to keep the cables in place, I think)

I see some damaged to the white cables sheath (from the retention clip) but cannot tell from the image if it has cut to the copper cable or if it has been badly pinched.

The actual antenna are behind the screen so that could be something to look at but it does require removing the screen…

Edit: You should try a Linux live disk to quickly check if performance is the same, Fedora is probably still a good choice, I have been using Fedora 35/36 without WiFi issues. The E4200 I believe should be getting 150 Mb/s link speed at 20MHz. How are you checking link speeds?

Linux is beyond my capability right now but I want to learn and this experience may be the catalyst.

My internet plan is marketed at 100mbps. My wired PC is pushing 115 mbps. When my old phone is an inch from the router it gets 80mbps.

I might take my laptop to a Starbucks just to rule out some kind of incompatibility with the e4200. I also ordered an antenna assembly from framework to rule out physical damage to the wiring. Up close I don’t see any penetration to the copper, only tiny dents in the plastic in a couple spots.

To be clear I’m only suggesting to run the live disk not installing the OS.

It is actually very easy with Fedora media writer. You can download and write the .ISO all within the app. All you need is a USB stick that you are happy to format and about 5/10 minutes!

After that you when you boot from it and choose “try Fedora” not “install Fedora”. Don’t worry you won’t accidentally install the OS even if you click install, there a several steps before any changes are made and warnings beforehand.

If you haven’t gotten the latest drivers from Intel directly try that.

Otherwise you’re likely looking at issues related to the E4200. One of these issues is the channel the router is set to. It says auto but this if often not optimal.

See this extremetech article for more details: How to Boost Your Wi-Fi Speed by Choosing the Right Channel - ExtremeTech

I already installed the latest drivers with the Intel DSA app thanks to Rupert Woods early post.

I tried setting channels manually:

Baseline I’m getting 17mpbs when its set to 20mhz and auto.

Channel 1: dropped to 2mbps
Channel 6: increased slightly to 19 mbps
Channel 11: 17mbps


My new antenna module arrived today and I installed it minutes ago. Nothing changed. I have the exact same speeds.

I learned how to remove the display, and performed the scotch tape touchpad fix while I was in there, so not all is lost.

In light of putting in a fresh antenna, what could be causing this speed drop?

Next steps IMO would be: Try Starbucks/a different access point, and/or the Fedora live image (not installation) as suggested before. Both of those are free (modulo a coffee drink) and quick, so worth the time.

Assuming no change after those, then I’d look at replacing the wireless adapter. You already re-seated the connectors when you replaced the antenna so that possible point of “failure” was presumably ruled out.

Sorry if it was already mentioned but Win 11 has a network troubleshooter, so you could try that and also make sure there isn’t any metering enabled. You can do a reset of all wifi settings to see if that clears up the slowness. I got this info from a search and looked at this guide:

Another thought I had was if there is some power saving setting in Windows you can change?

Seeing your speed changed a lot with channel, does the same apply to your other devices? Have you tried the 5G band?

You can used a program like inSSIDer to get more info on you WiFi surroundings (help find most optimal channel ect)

Honestly if you are comfortable changing you routers settings I think you have the ability to click “next” a bunch of times in the Fedora media creation app. :stuck_out_tongue: