We are unable to calculate shipping rates for the selected items

Trying to order a laptop, when I go to checkout I get the message

“We are unable to calculate shipping rates for the selected items.”

Any suggestions as to where I look to resolve this? I’m ordering from Calgary, Alberta Canada.

Thanks,
Ken

Weird, are you trying to ship to a PO box or something unusual? Do you have a rural or urban/suburban postal code?

Shipping to Canada seems to work very well, there are quite a few of us here.

1 Like

I have just a regular street address in Calgary.

Very strange. And I presume you’ve never had shipping problems before? FedEx can ship to your location just fine?

I wonder if it has something to do with Calgary’s interesting street quadrant system. Such-and-such road SW, this-and-that road NE. I hear there are streets in Edmonton where this doesn’t matter but it’s very important in Calgary. But the postal code lookup should take care of that.

Contact support? But they would likely defer to FedEx who may not know a thing about it except the local depot.

Deliver it to your place of work/friends/family?

So, I tried to deliver it to my son who also lives in Calgary. His address does not have a quadrant designator (i.e. no SW, NE etc). I still get the same error however.

I’ve never had a courier have a problem getting products to me before.

Is it possible that there are some components in a DIY laptop that are sold, but really can’t be delivered to Canada? There really aren’t that many options so I don’t have anything unusual.

Now I entered the address for my brother in Edmonton - and I got the same error. I don’t think it is related to my address, but perhaps it is something in my order or profile perhaps?

Don’t think so. It didn’t have a problem with me here in Ontario but I didn’t order anything unusual either.

I wonder if it doesn’t think your credit card is associated with your address.

I’ll PM you a neighbour’s addess, maybe try that to see if it will accept anything.

I don’t even get to the point where I enter my credit card. I can’t get past the part where I enter my shipping address!

Have you set your currency to CAD?

I have the CAD flag in the upper right corner of the screen, so I believe the currency etc should follow from that. The URL I am on is “https://frame.work/ca/en/checkout/address” which looks like the CAD site.

I just tried your Cambridge address and received the same error.

Here is my configuration. The only thing that might be a little bit unusual is that I ordered 6 expansion cards and no SSD (Memory express has the same SSD on sale today for $250 off!). But these are certainly acceptable options according to the web site…

Configuration

$1,761.50

  • CPU: Intel® Core™ i7-1165G7

  • WiFi: Intel® Wi-Fi 6E AX210 No vPro®

  • Operating System: Windows 10 Home (Download)

  • Memory: 32GB (2 x 16GB) DDR4-3200

Customization

  • Bezel: Black

Included

  • Keyboard: US English

Included

Expansion Cards

  • 1 MicroSD

$25.00

  • 2 USB-C

$24.00

  • 1 HDMI

$25.00

  • 2 USB-A

$24.00

Accessories

  • Framework Screwdriver

Included

  • Power Adapter - US/Canada

$64.00

It sounds like something on the site isn’t working. Everything seems normal yet you can’t move forward.

I know everyone says this, but try clearing cookies and cache and starting over. Try a different browser too.

The site is still new, you could have encountered a misconfiguration. I know for a while it wouldn’t let me choose between preconfigured or DIY, then it thought I had an incomplete configuration on the go but couldn’t actually find it. Works better now.

I am using Chrome on my desktop computer to do this. I will try edge on a different computer and see if anything is different.

OK - I tried that on a different computer / browser, and got the same results. I’m down to thinking there is either something corrupted in my account setup or framework is having site problems (in the latter case I would have expected to see a few more people chiming in here with “me too” and such :slight_smile: )

I guess the next step is to create an entirely new user and see if that works.

1 Like

As another experiment I deleted the configuration of the DIY laptop I wanted and configured an entirely new one (with only 4 expansion cards and with an SSD) - and I got the same error.

However - If I selected a pre-configured laptop (I selected the most basic model) - then it worked. So, there seems to be an issue purchasing a DIY model. I assume there are no restrictions about buying DIY models in Canada?

1 Like

I tried a further experiment and configured a DIY laptop exactly like the base pre-configured model. I get the error on the DIY model, but the exact same model (pre-configured) works. I’m leaning towards a webpage problem at frame.work - so I’ve sent an email to support to see if they respond. Hopefully they will also see this thread.

2 Likes

Thanks @Ken_Wiens I have reported the problem and we will look into it right away.

3 Likes

I have done some more experimenting and have determined that this is related to purchasing the OS. If I add an OS (eg Windows home) to the configuration, then the web page cannot calculate the shipping and you are hooped. By configuring a DIY laptop without an OS, you can continue past the shipping section in the ordering process! So I guess the workaround is to order your OS elsewhere. (I didn’t try this with windows pro, but I suspect the problem has something to do with shipping a downloadable component or something with licensing from Microsoft Canada)

1 Like

I tried this again today and it seems to have been fixed now. At least it is if you configure and purchase the laptop via the marketplace (which appears to use the same configuration and shopping cart pages as pre-market place).

1 Like