Weird Win10 WiFi problem

Hi - I have had Windows 10 and Ubuntu 20.10 both installed and and working well. after installing the Windows driver pack WiFi worked. I also updated the bios to 3.07 before I did an image backup of the Windows partition and wiped the drive to play with some different setups. After wiping the drive again (gparted deleted all partitions and new partition table) I restored Windows to the internal disk using Image for Linux and it booted right up BUT WiFi not working. Win troubleshooting says I haven’t chosen to connect an available network but when I choose show networks the list is blank - Airplane mode is off. When I look at troubleshooting details it lists the five available networks in the log. I have reinstalled the driver pack but no difference. Fingerprint reader is fine and I haven’t noticed anything else not working. i7 16gig 1T NVME and 1T USB all from framework. WiFi is fine on a Ubuntu 21.10 live usb

I’m guessing this is just some Windows screw up related to the backup/restore process. I ran scannow but that didn’t make any difference even though it claimed to have found and repaired errors. Since this was a fairly new install and I don’t use Windows as my main OS anyway I decided not to waste any more time, reinstalled and all is well.

Hey - I have the same issue and I haven’t restored the OS. I’m running Windows 10 and have been using the WiFi since I got the laptop 2 weeks ago with no problems until today. Today it just went away. When I go to Network and Internet settings it doesn’t even show WiFi as an option. Airplane mode is off.

I went through the network troubleshooter it says there are no problems. It only shows the wired network, though (I had to use a usb-c dongle to make a wired ethernet connection). I opened up the logs from the troubleshooter and it only shows the usb ethernet adapater.

I reinstalled the driver pack but no joy.

Any ideas?

I’m having the same problems.

Running on Windows 11. Anyone have a solution to this problem?
I am tempted to reinstall the OS