Windows 10 crash during install

Hello, I’ve just received the batch8 DIY edition and after installing the ssd and ram, I launched a windows 10 installation via usb flash drive. It crashes in the second step (after copying windows files) at around 70%. I tried to change the usb key I’m installing from, same, tried to remove and reinstall the ssd and ram, eventually tried the installation 4 times and it blue screens each and every time.

I think it could be a ssd or ram issue but don’t know how to test those hypotheses.

Thanks for you help.

Edit: I continued searching the internet for an answer. [SOLVED] - Built a New Computer, Windows installer keeps crashing... | Tom's Hardware Forum This looks like the same problem I have. However, it’s apparently a mother board issue. I hope this is not the case T_T

First do you know what version of the BIOS you are using?

Second, what is the brand and model of the SSD?

Third, what is the brand and model of the RAM?

As you mentioned these are your most likely candidates as the culprit of the problem you are facing.

I would also encourage you to contact support and open a ticket with them. They can give you better answers regarding RAM and SSD compatibility.

Hello, thank you for your answer. The ssd and the ram were ordered through framework DiY so I supposed there were no compatibility issue there…
so :

  • 1TB - WD_BLACK SN850 NVMe
  • 16GB (1 x 16GB) DDR4-3200 (crucial)

As for the BIOS, where can I find the information ?
You’re right, I’ll open a ticket with support.

Alright, after tons of back and forth with Framework support that was present but not really helpful (they asked me to a bunch of stuff, upgrading the nvme ssd’s firmware, reset the main board…), the issue was still there, still crashing at the same place. I got really suspicious with the RAM and tried memtest86 to test the RAM (first time doing this, you learn everyday), and here it is, errors everywhere. I went back to Framework’s support (the RAM was bought along the DiY laptop). They directed me towards Crucial’s support, we sent them the faulty stick and they gave us another one that just arrived yesterday… And YES it’s finally working !

tl;dr : If you have the same symtpoms it’s probably the RAM. Test it with memtest86 (be sure to check the settings to change the screen size before launching the test).

1 Like