Windows 10 installing problems

Hi there,

I do have problems installing Windows 10 and couldn’t find any help with it.

At the moment I have Linux Mint on the Laptop but would like to install Windows 10 now, to get a dual boot system.

I used my other computer, a Mac, to download the Windows 10 iso from Microsoft, formatted a 16GB USB-stick, using the SD Card Formatter app and than the BalenaEtcher app to flash the USB drive with the Windows iso file. Here, a note popped up that I should use Boot Camp to flash the USB stick, but Boot Camp does not run on the M1 Macs and I figured this note would only be of importance if I wanted to install Windows on my Mac. Also BalenaEtcher had no problems flashing the USB stick with the Windows 10 iso. After that it also showed up in the Mac Finder.

I then switched to the Framework laptop and after a while could set the boot settings to start from the USB stick (btw, is there a known procedure, when exactly to press the F2 button at start???). Anyways, Windows installation started and during the first steps it asked for drivers that obviously were necessary to install Windows. As there were none, I couldn’t proceed the installation process.

After some researches I re-downloaded the iso file from Microsoft, tried two other USB sticks, tried an installation via the Mac’s terminal, etc. etc., but the results always were the same: lack of necessary drivers.

Questions unsolved:

  • A possible conflict with the FAT32 format of the USB stick, but BalenaEtcher seemed to have no problem with that during the flashing process. Also the installation started.
  • BIOS settings, but again, the installation process started.

Any ideas what I could try next? I do not have a Windows computer and don’t know anyone with a Windows machine.

Have you looked at Search results for 'windows 10 install' - Framework Community and especially

Thanks, amoun! Yes, I first searched this forum, and other forums in the internet since yesterday. Some people had the same experience and could solve them by switching to a different USB stick, changing BIOS settings, etc. But all had a Windows computer in reach and were able to use Microsoft apps to solve their issues. I don’t.

The thread you linked shows a different problem. I didn’t get that far. The missing driver note popped up right after the window where one can choose the language and location.

1 Like

I had this with my AMD PC. It turns out you can download and flash a perfectly valid Windows installer to a USB drive that just happens to be utterly broken simply because of the way it was flashed to the USB drive.

It was only when someone on Twitter bought the same motherboard as me and went through the same process that we discovered this issue.

I don’t recall the exact fix, but it was probably “just use Windows to download the Windows Media Creation tool and use that to flash the USB drive”.

From memory (this was a year ago or more), it’s a stupid UEFI issue.

Unfortunately, the Windows Media Creation Tool is a Windows only thing. Meanwhile I also tried some Linux based ideas, but had no success. The SSD should be ok, as it had a Windows 10 installation on it, before I nuked it for the Linux use.