Windows 11 crash. Anyone get a WHEA Error: a fatal hardware error occured?

** This is Windows 11 Home v 10.0.22000 Build 22000

I was in the middle browsing the internet when I put my laptop on the table, not gentle but not rough.
Out of nowhere the screen glitched and 10 seconds later my laptop hard powered off. There was no blue screen or anything.

I’m posting this to see if anyone has the same problem or if I can help debug in someway.

Here is the event from Event Viewer.

From popular internet pages looks like some kind of RAM defect.
But before you open up the laptop and start to throw RAM sticks into trash can, it’s extremely highly likely that what happened is that the vibration you caused by putting it down on your table have unseated one or more RAM slots, which … well, is not wanted.
I had the same issue with my Dell Inspirion 13z, where I even run BIOS tests and it wont go past either graphics card or memory. Re-installing the memory solved the problem.
However, if the issue persist, then it’s either a actual RAM defect or a broken motherboard.

This issue happened again. Dropped my phone 3 inches above my lap into the trackpad. Was able to take a picture of the issue. I swapped the ram slots based on the kind reply from above the first time it happened.

It bypasses the Blue screen of death and goes straight into this frozen minecraft background.

1 Like

holy scrap …
That’s the most scariest thing I have ever seen any computer do (beside from emitting a “pop” sound and have visible smoke instead)
Did this happen immediately after you drop the phone?
If so there’s likely some connection issues with some connection with vital components (not even the SSD). CPU, RAM and the sort.

Immediate thoughts are, again, RAM slots. But there could also be manufacturing defects (e.g. CPU not soldered properly or one of the solder balls on the bottom of the CPU cracked), or something might happened to the RAM stick (since the socket is SMT thats not a issue)
I will do a tap test. Open the bottom cover, turn the machine on, and gently tap components (e.g. RAM sticks, heatsink) and see if you can identify where vibrations can cause issues.

1 Like

I’ll review all the components to make sure they are connected correctly!

It’s a DIY with all components ordered through framework so I’m hoping it’s just something loose :crossed_fingers: .

1 Like

ah. that might explain.
Hopefully you didn’t do something awful like, say, cracking the die on the CPU or cracking the solder balls under the CPU

which may happen if you flex the board too far (in common cases of mis-handling)

how did this turn out @TheChonch ?
I have now a similar issue on my batch 8 model, also diy but windows 10
it happend 2 times in like 10 minutes but without dropping or anything, it was just sitting there, I was watching a clip in telegram


Unfortunately nothing. I tried:

  • Swapping around current RAM.
  • Buying NEW ram from framework(so same model).
  • Last ditch loosening of screws on the motherboard connected to the chassis.

Best I could do was narrow the impacted spot to between the wifi card, right ram slot, and right QR code instuction pane. It is REALLY sensitive and even a light tap from the screw driver slipping around that area causes it to bork out.

My solution was basically just to get a standing docking station and not use it like a laptop :frowning:

I don’t know, it sounds like it might be worth asking for a mainboard swap. To me it seems like something is potentially shorting out, etc.

@Bingo having a similar issue to you where the laptop is crashing while just sitting there. although it’s been triggered by movement in the past. what are you seeing in the event log, in my case it’s source is from kernel-power

Hmm. Mine was batch 2(3?) and even though it was minimal, I have touched the motherboard check the screws fittings.
Anyone know how lenient they are or replacement motherboards?

@TheChonch it looks like I can reproduce it, I have to watch certain videos in telegram chatrooms, literally everything else doesnt produce it, I even run some occt tests since yesterday
btw my ram is Crucial CT32G4SFD832A.M16FRS (dual rank/dualchannel 3200MT/s)
I will do another test with some old hynix ram to see if I can force that type of crash again.
For me its not a big deal, when it only occurs while watching clips in telegram, but when you cannot use the laptop as a laptop I would recommend to ask framework for a solution, this laptop and the hole company is about best user experience.
@emoticon for me it looks like its whea error with ID 1, I didnt find any further information in eventmanager

Kernel-whea will not produce ram related messages without ecc, you would bsod or have corruption. It’s the cpu or broken trace and broken ram trace specifically would just silently drop the module in my experience. And ecc errors are more specific than what you get when cpu is faulty

Consumer ddr5 doesn’t support the kind of ecc that would report to the host (fyi if they release a new version)

Problems like this just once again show it’s not worth the tiny production savings to omit ecc

1 Like

update from my end. my issues was fixed once i changed ram. i initially had one stick 16gb from framework. i now have two 16gb Crucial CT16G4SFRA32A (all my local store had from recommended list). no longer having any problems

update from my end as well, for me it also fixed the issue to change the ram from CT16G4SFD832A.M16FRS to CT16G4SFRA32A.M8FF.
I got send CT16G4SFRA32A.C8FB before I got the CT16G4SFD832A.M16FRS, because they send me the wrong item, these also worked fine and even were a bit faster in benchmark than CT16G4SFRA32A.M8FF. All 3 were in a 5% window in passmark mem.

long story short: CT16G4SFD832A.M16FRS seems to be not that compatible with the framework laptop

1 Like

Well slather me in BBQ sauce and call me a McRib.

My OG RAM and the replacement RAM I got from Framework were ALL CT16G4SFD832A.M16FRS.

The pic shows SFRA832A, not SFD.
Lol. Loved the McRib comment though.

1 Like

Ahh, good catch. I rectract my statement lol.

Welp. It’s finally happened. It crashed without a bump.
I had it in my docking station playing a cheap steam game when it borked. I was fine with the crashes since it was docked 95% of the time so no accidental bumps. But this one hurt lol. Finally talking to customer service to see my options.

Could it be a thermal issue?
The Framework laptop has the air intake at its bottom. This is slightly covered by the other laptop next to it.
The air outlet is in front of the display, or when the lid is closed at the back. This is also pretty well covered by the bracket of the docking station.

It’s not necessarily the cause, because the CPU should throttle anyway. Just an idea.

Edit: At least the bottom intake can’t be an issue, because when the laptop sits on a table, there is even less space.