Zoom virtual backgrounds don't work, FW 16, Ubuntu

Just got my new Framework 16 the other day and have been setting it up. Zoom installed just fine, and even works without a hitch. However, if I attempt to select the “blurred” virtual background (or any other virtual background), the video feed completely freezes and will remain frozen until I turn off the virtual background

I am running Ubuntu 24.04
Framework 16, 7840HS, no dGPU (is this potentially the issue? can the iGPU not handle virtual backgrounds?)

I have read and followed the zoom support pages on enabling virtual backgrounds for linux found here, but it seems to be oriented towards enabling the option, and I already had the option there, it just didn’t work. But either way, following the instructions didn’t do anything.

Any help would be greatly appreciated.

It is proprietary software, not open source so there’s not a lot I can do for you. If it doesn’t work, you can submit a ticket to zoom. Sorry about that. Maybe another service can be used? Blurring the background is a complex function often delegated to the GPU so if the driver support isn’t 100% there it might just not work.

I’ve been using Zoom purely form the browser (Firefox) on Linux for several years. Relying on the Zoom Redirector extension to suppress requests to download the native app.

I just tried a test meeting and I could enable blur and virtual backgrounds.

Hope this helps; I’m running Fedora 40, GNOME on Wayland on a FW 13 AMD machine.

you might be able to find a virtual background plugin for OBS, and if you can then you can use it in zoom on linux.

before opening zoom, open OBS and get it connected to your camera and then set one up to your satisfaction. then, close down OBS. load the v4l2loopback kernel module with sudo modprobe v4l2loopback (you will likely need to install it first, you can also add this module to be loaded on boot if you do this a lot). reopen OBS, make sure everything is still working, and click the new “Start virtual camera” option. then you can open zoom (or any videoconferencing software), make sure it is set to use the virtual camera (if it tries to use your main camera nothing will be displayed). you should then be able to do virtual backgrounds via OBS.

also note that obs requires setting output mode to advanced to enable hardware accelerated encoding, at least on fedora with an amd gpu. idk about ubuntu (its probably easier since i think ubuntu ships with better codec support than fedora so you dont need to install different builds of the video acceleration libraries).

also note (the sequel): you can use this to do screensharing even if the host forbids it (maybe useful if helping a less tech-savvy relative over zoom) although it will be blurry. this also lets you reliably screenshare from a wayland desktop (if you want to get rid of the blurriness you can disable your virtual camera in zoom, then screenshare “content from a second webcam” and pick your virtual camera, which will make zoom optimise the share for resolution)

Works for me, using KUbuntu 22.04 LTS and a licensed version of Zoom (Work). Using it every day and even made my own backgrounds :slight_smile:
They have a sizing requirement → 1920x1080 if I remember. Check the details.

also zoom for linux has always had worse virtual background support than on other platforms (static image only, physical greenscreen required all were requirements on linux back when i first used zoom on linux - i think the physical greenscreen requirement got removed at some point)

That is correct. Works nicely here for some months.

the blurred background does work perfectly using the browser redirector. So thanks for that suggestion. I’ll continue trying to get it to work in the actual application, but until then, I’ll use it in the browser.