Viability of an ML 1220 rechargable battery for RTC | CMOS (11th gen)

I reseated; flex cable socket, RTC and battery connector. All is well and my Framework is running like deere. (Texas pun)

1 Like

I’ve had the OK from the OP to hijack this thread about the usabilty of the RTC.

The simple issue is that is discharges causing stress to the user and possibly to the battery holder.

There are two issues I’m not happy with
a) That the charged RTC may not last a week and requires the user to workaround this problem.

b) That the reasoning for using a rechargable is ‘sustainability’ etc.

For perspective I have no problems so far as I use it plugged in daily, but the thought that I can’t leave ot for a week or two is more that a little uncomfortable.

So it may be usefull to have the moderators move other posts around this but otherwise these issues are being voiced at

The basics are

  • Why on earth does the RTC battery discharge in a week. I have common RTCs in other laptops that are 4 to five years old. This means the rechargable battery is 100 times less efficient and no doubt will have to be replaced underminig the ‘sustainability’ argument.

  • How long does Frameowrk think these rechargable RTCs are going to last

  • Do they really think that their own opinion that they discharge in ‘two or three weeks’ is of any comfort.

  • Why can’t the RTC be kept alive from the main battery, which relates to the original post ~ why does it take so long to charge ?

  • Is this upcomming 3.08 resolving any RTC discharging or is it the main battey only.

  • What is the RTC doing ?

  • Why even use it , just for a clock. My phone doesn’t have one and my 20 year old Dell just has the wrong time.

I will write directly to Framework with my concerns and post the text and their reply here, which I’m pretty sure will promote further discussion.

All the best

Maybe we can come up with a set of questions and ideas to Framework.


Can I also add the question of:
Why is this a thing? “processor goes into a bad state with low RTC battery voltage”

I’m guessing that addressing the RTC battery drain (whatever that root cause is) will mean the bad process state would occur a lot less frequently (say, once every 5 years, maybe)? As opposed to every bloody week (for some users).


I can offer to help test this out. I may wind up wishing that I hadn’t, but I will. I have a second framework that is a family machine and used infrequently. I typically shut it down when done using it, so it’s not in sleep mode. I have not run into the no-boot case, but maybe I haven’t let it sit long enough. Typically it gets used weekly, if that.

In order to help me to test this, can someone summarize what the situation was leading up to the issue? There may be many different modes to test here, so I will try to collect them and keep a list going.



For visibility here’s the initial thread I was a part of:

@lbkNhubert for testing I have simply left the unit fully powered off for at least a week before trying to use it again. The power button fails to start the boot. I am unable to get the laptop to boot until I plug it into AC


Thank you for the input. However a more worrying concern is where someone has to open the laptop and remove the RTC, to let it recover enough so that it will allow the laptop to start when plugged in.

1 Like

Oh sure, you can definitely open it up and remove the battery following the reset guide every time but it since it doesn’t really resolve the drain issue I’ve since stopped bothering.

When it fails to boot for me I simply plug it into the wall now

1 Like

I think the issue is that if you leave the RTC to discharge below a certain level you cannot start by just plugging in :cry:

I could quite get my head around it all, not that I should ‘have’ to but not being able to power up when plugged in ???


This is such a sad, depleting, depressing issue to have on a laptop in 2022. #DarkCloud


That would have been sad decades ago, but never heard of it until now ~ but isn’t there a silver lining to every cloud and a gold one to a dark cloud ~ waiting ~ waiting


I originally started seeing this about a month or two ago. I really only use my framework once weekly to play D&D with some buddies on the weekend. After a couple of missed sessions, I stopped being able to turn the laptop on at all, and started pulling the RAM, SSD, RTC battery, etc. out to see if that would help, and after a bit of tinkering, it would turn back on. Usually after plugging it in to the charger for maybe a minute total. Then it started happening every week that I’d have to do this.

Since speaking with Framework’s support team, and not having a pleasant experience with it, but that is separate, I had left the laptop charging for about a day and a half, and stopped experiencing the issue while they were sending a replacement main board. I haven’t had the issue since, and have occasionally checked the RTC battery voltage. It’s been hovering around 2.8 V pretty much the whole time after.


So was the issue resolved with the replacement board or just stopped happening altogether on the original? Which model board do you have?

1 Like

I have the i5 model, though I don’t believe this is an issue with any particular model from what I’ve seen on the forums.
I was only testing with the original for a few days before the replacement main board arrived, and I haven’t even had that for a month yet. It hadn’t happened on the original for the few days after I tried leaving it charging for an extended period, and it hasn’t happened on the new one since, as I have been careful to put it on the charger on weeks I wasn’t using it.

1 Like

I dont buy the sustainability justification at all. Non-rechargable button cell RTC batteries last YEARS and can be recycled (at least in the UK). This is a case of micro-optimisation that is far more trouble than it is a benefit.


Forget that comment it’s a typo. It should read “it just wont boot from battery alone”.

This problem has been solved now… button cell holder was not soldered to board properly. New main board fitted and everything is fine. Did notice further comments on button cell depleting quickly. This is happening to me now. But all other problems are solved. Sorry for the confusion.


Took 17 emails with support before they admitted there was no fix - hardware or software planned for this. I asked to return my relatively unused machine since I can’t boot it up without connecting AC. They refused. I think they are trying to downplay this design flaw and it really has me disheartened about the company.

I am considering joining Floatplane and seeing if I can bring it to Linus attention at the next WAN show. He’s exactly the kind of person that would call out how terribly this is being handled.

I was so optimistic for framework to bring the change we needed. My disappointment is immeasurable and my day is ruined.


Ok I gather this is a yes from the other topic.

I will be ‘writting’ to Framework with views which are simialr to yours very dissapointing and asking for some sensible explanation and options to mitigate.

Thanks for your input and sorry you’ve had this horrible experience.

Luckily for me I use the laptop every day for many hours, usually plgged in, so I do not suffer but knowing I can’t put it away for a week or two is very disconcerting.

There has to be a solution


If possible could you send some references to these? I’m curious what went on here! :smiley:

1 Like

You mean copies and quotes.

Without reading all you can get a very distorted and unbalanced approach and for legal reasons it may be good to ask Framework if you can see their correspondence as by definition it wasn’t for the public to read.

I will be emailing support and explaining I want to copy my questions to them here and for them only to answer if they are happy for me to copy their replies too. :slight_smile:


My guess is tech support is doing their best but this is an Engineering and Product Management issue. Unfortunately, there is a serious lack of transparency to the public over the real root of the issue and its making me very suspicious of framework overall. I feel like I’ve been suckered into the exciting idea of an open and transparent company that wants products to be good, fair, and to last but in practice there is still quite a bit of obfuscation going on.

I would really prefer framework leadership to acknowledge there is an issue and agree to look for a fix. Given they are signaling the opposite via support - they believe the issue does not affect the majority of users (but still there is an issue) - I’d want them to offer to take my machine back for refund as I believe it fails to deliver what is generally expected by customers of this type of technology.