Fedora Linux 35 (Fedora 35) on the Framework Laptop

Fedora 35 is now released and has effectively full support out of the box for the Framework Laptop.


A detailed step-by-step guide is available here. Short instructions are below.

  1. Create Fedora 35 USB installer or Live USB drive using the Fedora Media Writer
  2. Insert the created USB drive into your Framework Laptop
  3. If there is a bootable OS already installed on your internal drive, tap F12 repeatedly while booting to bring up the boot selection menu, and select the USB drive.
  4. Try out the Live version of Fedora 35 without installing, or click the Install button to install it on your internal storage drive.

Specific Fedora & Linux Issues Fixed in this Release

:white_check_mark: Wifi works
:white_check_mark: Bluetooth works
:white_check_mark: Fingerprint Scanner works (hardware issue of erasing old fingerprint scans fixed here)
:white_check_mark: PSR / Panel Self Refresh disablement is no longer necessary

Sort-Of Fixed - Requires Minor User Intervention

:ballot_box_with_check: Mic in via Headphone Jack - create the file /etc/modprobe.d/alsa-base.conf containing the text options snd-hda-intel model=dell-headset-multi, then reboot.

Potentially Still Unresolved / Needs Further Testing

:question: Sleep / Suspend - a brief test of s2idle vs. deep revealed no major difference between the two as far as battery drain (still could be better), and deep still takes ~15s to wake, so this still seems to be an issue specific to the Framework hardware. To improve your battery life, see this thread. It is reported that the latest BIOS version 3.07 improves the battery life dramatically.

  • Sleep mode: deep: It is reported that on Kernel 5.16.5, there is an issue that s2idle doesn’t work. To change the sleep mode from s2idle to deep, run grubby --update-kernel=ALL --args=mem_sleep_default=deep, then reboot. See this page for details.
  • Sleep mode: hibernation: See this page. Note that the hibernation might not be supported on Fedora. See this page.

:grey_question: Fractional Scaling - It is still not available as a default option in Gnome 41. The assumption is that it’s still an “experimental” feature for Gnome and this issue is not specific to Fedora or Framework. To enable fractional scaling like 150%, you can run the following command and then reboot: gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']".

:grey_question: GRUB “Scan Line” Glitch - this seems to be a GRUB issue and possibly not Fedora or Framework specific - see this post and the replies to it for additional details.

Reporting to upstream project or Fedora

To fix your issue, it’s important to report the issue to the upstream project or Fedora project.


Here’s a more specific list:

:white_check_mark: Wifi
:white_check_mark: Bluetooth
:white_check_mark: Fingerprint Scanner (not including hardware issue of erasing old fingerprint scans)

:question: Sleep / Suspend - I did a brief test of s2idle vs. deep and saw no difference, although deep still takes ~15s to wake. Maybe someone that knows more about this issue than I do should test further?
:question: Fractional Scaling - I don’t use it, but it was not available as a default option in Gnome 41. I guess it’s still “experimental”?

:x: Mic in via Headphone Jack - I honestly didn’t know this was an issue, but I just tested it and sure enough it does NOT work.

I’ve revised my original post to read nearly everything.

@gjason the mic input problem may be fixable:

Which Linux kernel is your F35 installation? I had trouble with sleep on Ubuntu when I updated the kernel to v5.14.

1 Like

@Atul_Ingle I’m on 5.14.1-300, and thanks to your tip above, my mic mini-jack input now works. On my install that file wasn’t even there, so I just created


containing the text

options snd-hda-intel model=dell-headset-multi

and rebooted.

Related, but does anyone else have grub take approximately 10 seconds after displaying to become interactive? There’s a small “scan line” as well that progresses from left to right across each row before then. Not sure if it’s related to LUKS or the particular grub version


Now that you mention it @Michael_Lingelbach, I’m experiencing the same issue here, and with no LUKS encryption. I added it to the list of issues on the original post.

1 Like


I actually had this same issue on Fedora 34 and was able to solve it by doing this:

Maybe it’s the same issue with 35?


Yes, I had this in F34. Something with GRUB’s console mode, I guess.
Resolved it by editing /etc/default/grub and changing




and then updated the GRUB config on /boot by running sudo grub2-mkconfig -o /boot/grub2/grub.cfg .


This was it! However, now I’m missing the icons for up/down arrow in grub (not that big of deal compared to the long load time before).

1 Like

That GRUB glitch is strange - I was able to fix it on my machine using the above info from @Michael_Lingelbach - all I did was edit

/etc/default/grub as root,


then run sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

and reboot. None of the stuff from @AlliedEnvy was required in my case. I’m going to edit the wiki to flag this issue as some random GRUB wackiness potentially unrelated to F35.


I can confirm the GRUB fix reported by @gjason

However I am having fingerprint reader errors.

The reader worked on Fedora34 following the suggestions.
I wiped the M.2 and installed a dual boot windows / fedora 35b
Since then I get “Fingerprint Device Disconnected” During addition of a new fingerprint.
I have been throught the windows delete procedure, with no change. I am still working on this.
the reader is now bad on all OSs so may be a hardware issue

I have another additional ‘feature’ no one seems to have reported - Touchscreen second monitors only do touch on the primary display. It is a GNOME issue, that may be resolved with settings.


I had an issue setting up the fractional scaling using -

$ gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’]”

However using the recipe here
for Wayland - All users

The fractional scaling is back and looking great.

Note the /etc/dconf/db/locks/ directory did not exist and needed to be created to get this to work.


I lost my wifi yesterday after a dnf upgrade, which updated the following packages:

I was able to get wifi back by rolling back all of those installs - I ran dnf history | head to get the ID of the last batch of DNF actions (which was 68 in my case), then downgraded all of the packages with sudo dnf history undo 68, and wifi was back after a reboot. Upon further investigation, it appears that installing iwl7260-firmware version 1: caused the problem, as installing it obsoleted & removed iwlax2xx-firmware version 20210919-123.fc35, which seems to be the driver package that was working for the Intel AX210. As instructed by Red Hat Bugzilla Bug 2010250, I ran dnf install iwlax2xx-firmware (by connecting a wired USB ethernet dongle) and wifi was back after a reboot.


There is now a newer version of this firmware package available that apparently doesn’t cause the AX210 drivers to be removed.

1 Like

The Fedora 35 RC 1.2 was released for testing yesterday. It seems the downloads are available here. I guess some of the issues are fixed from the Fedora 35 beta.

Related tweet on the twitter: https://twitter.com/fedora/status/1452986673097281546

There is another thread: Fedora 35 beta on Framework laptop about Fedora 35. But I think it’s better to use this thread.


I upgraded from 34 to 35, and I haven’t noticed any problems.

Note the Fedora 35 will be shipped live on coming Tuesday 2nd November 2021.

1 Like

I guess I was misled by what I read at https://is.fedora.released.info/, where it says, “It’s Out!” I will say that as someone new to Fedora it’s been oddly hard to find an official Fedora page that clearly says when or under what conditions Fedora 35 will be considered released.

That’s pretty fair on both your and Fedora’s part because Fedora didn’t know they were releasing on the 2nd until yesterday.

The way Fedora does it, they have a target date for a Tuesday towards the end of April and October. On the Thursday prior to that Tuesday, a team sits down and reviews any final blocker bugs, proposed blocker bugs, and decides if the full release is Go/No-Go for the following Tuesday. They will evaluate and delay, week by week, as necessary until all the blocker bugs are removed, the final release date being the Tuesday after the Thursday meeting they give the release candidate the green light.

So, they didn’t know they would be releasing on the 2nd until yesterday and unless you knew this and knew to google “Fedora 35 final blocker bug status,” you wouldn’t know because Fedora doesn’t push a date until it’s ready.

The website you linked is referring to the release of the Fedora 35 beta which did happen in September, but it doesn’t seem to mention anywhere that it is referring to the beta.

Fedora does have a discoverability problem. They at least in my opinion have some of the best documentation of any distro on just about every aspect of their project, rivaling the Arch wikis and guides, but that information is spread out across multiple locations and is much less searchable which is why people who don’t even use Arch on their machines use the Arch wikis for troubleshooting while newer users to Fedora have trouble figuring out when the stable version of the next release is coming out because they haven’t yet learned the exact phrase they need to look for to get the information they want.


I am not sure about the website you mentioned. It’s not the fedoraproject.org domain. So, maybe someone created it unofficially with good intent. I can recommend the devel-announce mailing list as a primary information source to know the latest info such as release dates, or Fedora twitter account.

1 Like