USB C is not compatible with iPhone 15 / Pro / Pro Max

I’ve been running into a similar issue with my iPhone 15 Pro Max using a USB-A expansion card and this Anker USB 3.0 A-to-C cable on my FW13. My iPhone will always stay charging, but the data connection drops whenever I try to run a manual backup with iTunes such that it never gets backed up. The data connection lasts for a few minutes then drops and immediately reconnects. I’ve tried it with both 3.03 and 3.03b Beta BIOS and it’s the same result. The same cable works with my desktop fine for backing it up and syncing, but there’s a plethora of differences between it and the FW (AMD 5000 series, ASUS mobo, Windows 10 Pro, etc.).

One of my Anker USB 2.0 A-to-C cables works fine and allows the backup to complete.
One of my Apple C-to-C cables does the same as the OP, constantly disconnects and reconnects power.

Update: After testing the C-to-C cable, no USB cable would work with the iPhone for power or data and I kept getting the Windows error of “The last USB device connected wasn’t recognized.” There was also a failed USB Composite Device that showed up in Device Manager. This issue also caused my bluetooth mouse to drop connection after a few seconds and wouldn’t reconnect without cycling bluetooth off and back on, and would work only for a few seconds until it got dropped again. Restarting the laptop took care of these issues.

FW13 Specs:
AMD Ryzen 7 7840U
Windows 11 Pro
3.03b Beta BIOS (same issue with 3.03)
iOS 17.4.1 Build 21E236

Just replying here to note support haven’t been able to resolve this and also don’t really see it as a Framework fault.

This is not good enough.

you need to reach out to apple. It’s most likely their problem. Non-apple phones have all been reported to work fine.

Apple are going to go (internally, you won’t get a reply): “What’s a framework?” and go back to making all of the money.

This is a problem that only affects Framework devices.

I recently discovered that this issue is also impacting the Framework 16 laptops with the beta firmware. Same problems and symptoms as this Framework 13 issue. I tried opening a support ticket but that is going nowhere fast (it’s currently at the “we suggest disassembling the entire system, factory resetting everything, and take pictures and video while you’re at it” phase).

1 Like

I have the 15 pro max running 17.5 beta My FW 16 is on 3.03 and win 11 fully uptodate. with beta driver pack.

Left rear USB C
Left Middle: HDMI
Left Front USB C
Right Rear USBC
Right Middle USB A
Right Front Micro SD

i can confirm i have the issue in on the back left port BUT the Front left port it errors like it does on the rear but then it works without issue. just charges slow. (Note: after initial plugin to the front left i think the error was a remanent to the rear port error…as it works without issue)

1 Like

So you have been able to connect your iPhone to your FW?

Currently experiencing this with my FW 16.
My USB C is Top Left and Top Right. Constant connect and disconnect and I got the Windows error about not getting enough power (something like that).

I tried connecting via USB A to USB C but it wouldn’t even pop up a connection. I’m unsure if it was the cable.

EDIT: Friend suggested plugging into the back of the laptop and that worked. Charging wise though but not data so… I guess that’s sort of a useless tip.

Yes ports 4 5 6 the no power input ports should work. I have the front left as usbc as well.

I dunno how much this is Framework’s fault. I am no iPhone expert, but similar USB-C connection and charging problems have been reported before. As someone already posted here, this article mentions that iPhone 15 charges a power bank instead of the power bank charging the iPhone. It also seems that it happens on various computers; it might even be related to AMD Ryzen motherboards, as people reported it on different AMD laptops, although in the previous thread someone mentioned Surface Book 2, which is Intel I believe. Does it also happen on the Intel Framework?

1 Like

Would be kind of neat if we could just temporarily or permanently disable pd sink mode on a port or 2 so there would not be any ambiguity who charges who there. Maybe as a bios setting or ectool command or something.

I put a support request in about the FW 16 USB-C issue. Framework is aware of the issue but they do not have an estimate on when it will actually be fixed.

I was able to get limited USB connectivity by using a USB-C expansion card on the two non-240W ports located towards the front of the laptop. However, this experience was a bit janky and I wouldn’t trust it with anything critical.

Careful with them facts. You can’t tell an Apple customer that something is wrong with their Apple product. Cognitive dissonance will kick in :stuck_out_tongue:

Many have already posted examples of the Framework working perfectly fine with “other” phones but they will have none of that.

No need to be condescending. Clearly there is an issue that is likely to be Framework’s fault here, as it can’t be replicated elsewhere. Not so much of a deal breaker as this is something that can be worked around but still, this should really be investigated.

Please don’t try to accuse me of being condescending. It’s just a stereotypical joke, hence the tongue. I have an Apple fanboi best friend who also has this “unhealthy” brand loyalty where Apple can do no wrong that just makes things fun.

A quick google will show you that this issue with the iphone is NOT only on Framework…in all cases the common denominator is the iphone. Other examples reported are an iphone 15 trying to charge a larger device (like an ipad pro) or even a powerbank. Common sense deductions would conclude this is 100% the fault of the iphone.

Now, that does not mean Framework can’t work around this issue in firmware. They can probably have it refuse to charge the iphone when it detects one connected. But honestly, people should go to Apple as it seems to be a common issue with various devices when connected to the iphone.

The cynic in me would say Apple did it on purpose in retaliation for being forced to standardize on it with everyone else (non-apple phones do not have this problem). But it’s probably just an unintended bug or feature of the usb spec they didn’t get quite right in their first implementation on the phone…

I’ll have to give this a try.

I was able to get my iPhone to connect with a different USB-A to USB-C cable. Maintained data connection and charging to the iPhone.

I’m using Windows and an iPhone 15 Pro with an Apple C to C cable and it connects fine at least for charging, I’ll attempt data in a moment. On 3.08 BIOS, Windows 11 Pro Build 22631 23H2 and iOS 17.4.1 on 12th gen Intel Framework. I don’t experience any kind of hardware drops or my phone trying to charge the laptop, however, my phone was already low charge so perhaps the phone didn’t even bother offering? Not sure how PD is negotiated there.

EDIT: Backing up my iPhone went fine. I used an A to C cable from Best Buy as I saw some reviews that the “Apple Devices” software had issues with C to C and had to reboot my computer for the phone to be recognized after installation.

EDIT 2: I can now say that my iPhone successfully backed up using C to C cable. But now I do get the “insufficient power” warning from Windows…but it doesn’t seem to matter since the phone charges fine and data transfers without any visible errors

From what I’ve read in the USB PD spec, it seems PD is less intelligent than one might hope.

A device declares its capabilities, and preference. For example, capable of both receiving charge and providing charge, known as DRP (Dual-Role Power), prefers to receive. But if two devices connect with the same ability and the same preference, the one that provides charge is just chosen at random. So you have to just re-plug it until the charge direction is what you want…

1 Like

I went through the entire thread again to see if I could tease out why it’s working for me and nobody else….everyone including OP is using a Ryzen system, the one other person using Intel (13th gen) reported no issues. Fellas, this might be Apple but it just might also be AMD.

Yeah, people often ask, is a problem the device / peripheral’s fault, or the laptop’s? But sometimes it’s a little of both. Might not be even, either. Could be 80/20 the fault of the one and the other.

It may be component tolerances. Your phone and / or laptop might be bang-on middle component tolerance, so it works well. Others might have components that vary a little high or low, can still be within the tolerance range, so not qualifying as defective on a component level, but enough to cause bugs when paired with another device that also might be a little off.

2 Likes