Public Beta Test: 11th Gen BIOS v3.03 + Driver Bundle 2021_08_31

Note that we have since released 3.06 and an updated Driver Bundle: Public Beta Test: BIOS v3.06 + Driver Bundle 2021_10_29


Before we make any new Framework builds publicly available one of the most important aspects is to give our community a chance to evaluate the Framework BIOS and driver builds to provide feedback before we roll them out to all Framework users.

This is a really important step where we want to hear the community’s bug reports, suggestions or general feedback on the latest beta releases for Framework’s BIOS/driver bundles.

We have already been testing these releases internally over here at Framework as thoroughly as possible :muscle:, but since this is a public beta test there is always a chance you could encounter an unforeseen issue we haven’t caught yet; so please consider updating to these versions only if you are OK with that (and ensuring you have backed up anything essential first).

If you do notice any issues or have feedback please comment in this thread and the Framework team will be reviewing everything here and following up as fast as we can.

Thank you all for working together and helping us improve our releases!

Full release notes are available here.


Download: BIOS 3.03

Download: Driver Bundle 2021_08_31


LVFS update coming next week


While testing some Windows 10 stuff I went ahead and updated the BIOS to the 3.03 beta. Update went smoothly, no issues there.


For the new Chassis Intrusion Prevention feature, is it this button?

Is it expected to not trigger the chassis intrusion if the Battery Disconnect had been used prior to disassembly?

If the battery is drained to 0% (but the battery disconnect feature is not used) would it also not trigger chassis intrusion?

1 Like

Updated to 3.03 using a Windows to Go drive (since my main drive has linux). All in all install was easy. Just be aware after flashing, it may sit with the fans at 100% with nothing on the screen. Just let it sit, it will boot but it may take 30~ or so seconds.


Represents power states, I believe

1 Like

I don’t think the driver bundle installed Intel smart sound for me. There is a codec existence check which I guess failed for me

1 Like

This is correct (no typo) - Here is a an article (although a bit ancient) with more history and context to the S0ix modern power states


Great questions!

  1. Yep, we would be able to provide and install the previous BIOS version you were on.
  2. No dependencies that we are currently aware of; you can install either or both (that’s what I ended up doing personally on my machine!).
  3. We believe this is very unlikely (based on our internal testing the past few weeks), but if it is bricked, we will make sure to help you out :muscle:- as a last resort if it did end up needing to be sent back to Framework we can cover shipping costs; otherwise we do not yet have a procedure to resolve a bricked laptop (hasn’t occurred for us yet, hopefully I didn’t just jinx us!), but if we find reports we will publish one as quickly as we can.

Could you provide a screenshot of the issue you saw?

EDIT: A driver package reinstall seems to have fixed this.

I don’t have a screenshot of the installer message, but I do have an ‘unknown device’ in device manager.

1 Like

@nrp I tried the driver install again and it worked with the smart sound and realtek driver installing. Could have sworn that this was not the case the first time around. In any event, now to see if sleep works properly without it going into hibernate.

Edit: I still go into hibernate after a while sleeping

1 Like

Just performed both updates and they were successful. I also experienced what Chris2 did where after reboot it sat on a blank screen for ~40 seconds.

1 Like

It struck me that it was doing a memory training again… Seemed like the same place and amount of time as it initially did for that.

I’m on the new BIOS and drivers and have not noticed a problem yet. Going to check power drain this morning.


Really hoping the S0ix / modernstandby drain bug is fixed with this – if it is i’ll be keeping my preorder!

1 Like

You may as well keep it - they’re quick about updates (news and releases), and in general, by pulling out you’re making it worse for everyone else by an ever so little amount.
Setting PlatformAoAcOverride to 0 in regedit disables modern standby and re-enabled S3 sleep. It’s slower to wake, but quicker than waking from hibernation. And it drains very little when sleeping!


Stopping by quick to say thanks for all the feedback and questions so far on the release/release process (please keep it coming :racehorse:!), we are reviewing and keeping all of the feedback here top of mind for this and future releases. Thank you all!


We haven’t seen this yet, but going to try and repro on my end as well. How audible is the noise for you? Do I need to put my ear up to the laptop vent or should I be able to hear it generally when sitting a few feet away? And to confirm you are seeing this with the beta BIOS/driver package?

Edit: Just did a quick test and was able to reproduce on my end, will dig into this with the team. Thanks for the report!


it is a lever button;
as long as there is power to the mainboard it works (AC or battery);
the trigger would work if they tried to power it on or charge the battery while the chassis is open

1 Like

Whoa didn’t know S3 was an option – thought it was required to be removed with tiger lake. Guess I was wrong. Good to know this is an option, thank you!

1 Like

Excited for this. :smiley:

1 Like